0

Yesterday I installed i3wm and noticed that after the screensaver turns on, the screens turns black, but the monitors stay on (have two of them).

Up to now I was using Unity and the session locked and turned the monitors off after a set amount of time of idling.

What do I need to do to make them behave like this again?

this is what happens when using gnome-screensaver-command -l

Here's the output of xset q:

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  660    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
  • Can you please add the output of xset q? – Adaephon Apr 19 '16 at 11:12
  • Yes, added it now. – murtaugh Apr 19 '16 at 11:22
0

The the timeout values for all power saving features (Standby, Suspend and Off) are set to 0, which disables them.

You can set the timeouts with the xset command:

xset dpms [standby [suspend [off]]]

Where standby, suspend and off are the timeout values in seconds. For most modern displays there is (at least in my experience) no real difference between those modes. So if you set

xset dpms 0 0 600

it will turn off your display after 10 minutes of idling.

You can just add this as an exec configuration to your ~/.i3/config:

exec --no-startup-id xset dpms 0 0 600

If you want to immediately turn of your screen, you can do so with

xset dmps force off
  • Damn, seems like I was missing the dpms keyword in that command! This seems to be working, thanks! – murtaugh Apr 19 '16 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.