4

Running Xubuntu 14.04LTS

Originally, I was getting the following error

E: GPG error: http://mega.nz ./ Release: The following signatures were invalid: NODATA 1 NODATA 2

Did what this answer told me to do, tried updating again. New problem arose.

E: GPG error: http://mega.nz ./ InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)

How do I fix this?

1

3 Answers 3

7

I had the same error. Since its a recent issue, i believe it must have been a problem with the megasync server. I fixed it by going to /etc/apt/sources.list.d and then deleting all the files that started with mega using :

sudo rm mega*

Then run:

sudo apt-get update

3
  • While this fixes the immediate problem, wouldn't MegaSync be outdated if this is done? I would rather not have that, if possible. Commented Apr 27, 2016 at 4:07
  • 2
    Since that seems to be a problem on the mega side, i could only find that as an appropriate solution until they fix it. It's better than not being able to apt-get update Commented Apr 28, 2016 at 15:06
  • rather than removing mega* files, cp it somewhere outside, now remove the files mega* and then update ubuntu. When needed, cp back mega* files.
    – CKM
    Commented Sep 21, 2016 at 16:27
0

I'm having the same error.
Though the above mentioned technique may work, I'll suggest a more cleaner way

  1. Go to System Settings -> Software & Updates -> Other Software.
  2. Uncheck the option containing http://mega.nz ./ InRelease.

This will get your apt-get update working without having to remove your configuration settings.
Lastly wait for Mega to create a patch for this bug and re check the the box again using the same steps.

0

Megasync GPG issue is fixed by reinstall.(UBUNTU18.04) Open "software and update",then delete "https://mega.nz/linux/MEGAsync/xUbuntu_18.04/" ripository.

sudo apt-get --purge remove megasync
rm -rf ~/.local/share/data/Mega\ Limited
sudo apt-get update
sudo apt-get upgrade
sudo apt autoremove

Download megasync-xUbuntu_18.04_amd64.deb from MegaSync

sudo dpkg -i megasync-xUbuntu_18.04_amd64.deb
sudo apt-get -f install

launch Magasync.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .