this is the first time that I couldn't find an answer so this is my first question. I will provide as much information as possible. I have an ASUS router that has 2 HDDs. There is only 1 username/password to access the media while on the network. My PC no longer seems to be able to access it after an update.

After initially entering the login credentials and selecting "Remember forever" I had always (over 2 years) been able to access the drives by going to "Browse Network" in nautilus and clicking on the Router's Icon then clicking the folder I want to access. Today I had a security update which contained the following:

Now when I go to access the folders on the HDDs this pops up:

I select "Registered User" enter the username, password and select "Remember forever" then click Connect and the box pops back up greyed out with the fields reset to defaults.

If I click the connect button again the same greyed out pop-up keeps coming back over and over.

If I manually close it. A brand new pop-up appears that allows me to enter in the credentials. However, if I enter them again nautilus simply closes and I occassionally get a pop-up saying that Ubuntu has encountered and internal error etc.

There are 3 Phones, 1 Tablet, 1 Win7 PC, and another Ubuntu 15.10 PC that can connect to the network drives and read/write without issue. I should add that I ignored the update mentioned above on the other Ubuntu PC once I started to have this issue on mine.

So far the only way I can access the HDDs with my PC is to turn off my router's security for samba access. I really have no idea how to remedy this or how to get it back to the way it was.

Thanks in advance for any help.

  • 1
    I used to have the same setup as you, and no it doesn't work anymore on 16.04. I spent a lot of time trying to make it work. Those same changes have just, hours ago, been released back to 15.10 and 14.04. In my case I added myself and my password to the samba users stuff (i.e. `sudo smbpasswd -a doug'), whereas I has never had to do that before. – Doug Smythies Apr 19 '16 at 0:03
  • I just discovered the bad way, about the latest update as well.. still trying to get my samba server to accept windows users again. Android, Linux, and Apple devices have no problem accessing samba shares only Windows machines are unable to access samba after the latest ubuntu patch for samba. – AllGamer Apr 19 '16 at 6:54
  • Recently there was a serious security flaw detected in the Windows file sharing protocol as included in Windows and implemented by Samba for linux/unix systems. The recent updates of Windows & Samba contained the fix for that, but it seems like that breaks some setups, both on Windows & on linux… – JanC Apr 19 '16 at 23:11
  • There might be more information at samba.org/samba/latest_news.html#4.4.2 – JanC Apr 20 '16 at 0:13
  • … and samba.org/samba/history/samba-4.3.8.html – JanC Apr 20 '16 at 0:20

I first added the line client use spnego = no at the end of file /etc/samba/smb.conf, but it did not work. After I placed the line near the beginning of the file, the network drives worked.

| improve this answer | |
  • 1
    Cheers. This is what did the trick. I just had to put the line near the top right after the global settings break. Thanks. – user531897 May 2 '16 at 2:41

I had exactly the same problem. Adding

client use spnego = no

to the [global] section of /etc/samba/smb.conf solved the problem in my case. Apparently the default value changed to "yes" after the update to v.4.3.8, so I needed to explicitly set it.

See the online manpage for reference.

| improve this answer | |
  • I added the line of text as your suggested to no avail. The problem still persists. Thank you though. – user531897 Apr 22 '16 at 2:24
  • @user531897 did you check if there are any other values that changed their default after the update? e.g. "client use spnego" was not set in my smb.conf. This was ok before, as per the previous version the default value was "no". but now they changed it to "yes", so I had to set it manually. Maybe for you there is a similar problem with another option? – stack_horst Apr 22 '16 at 13:04
  • overall you had the right answer it apparently just had to be at the very top of the file (as stated by user18778) right after the global settings break... After a reboot everything works as it did before. Thank you. – user531897 May 2 '16 at 2:40
  • as @xenog remarked (in an edit, that should have been a comment): If you do not have the /etc/samba/smb.conf file, install package samba-common (sudo apt install samba-common). This was necessary for him/her on a fresh installation of Ubuntu Gnome 16.04. – stack_horst May 3 '16 at 14:30

I tried use smbclient to see what happened I got this:

SMB server does not support EXTENDED_SECURITY but 'client use spnego = yes and 'client ntlmv2 auth = yes'

I think this means samba client is telling the samba server use features which are not there. From use Samba's note above with this link I found this:

The impact of 'client ntlmv2 auth = yes' is that by default we will not use NTLM (NT Local Machine) authentication as a client.

Since I am not using any extended security I just turn this off as "client ntlmv2 auth = no" in /etc/samba/smb.conf. I have to added a line to override the default. Everything is working again.

| improve this answer | |
  • 1
    Welcome to Ask Ubuntu! Please don't add "thanks" as answers. Invest some time in the site and you will gain sufficient privileges to upvote answers you like, which is the Ask Ubuntu way of saying thank you. – Mitch Apr 27 '16 at 5:54

Check that you have winbind installed. Install it if haven´t got it and restart samba-ad-dc again. You should be fine after that.


| improve this answer | |
  • 1
    I installed winbind. Restarted samba. Rebooted just in case. Still no change. Thank you though. – user531897 Apr 22 '16 at 2:24

Yes after the latest update I did yestarday samba was not able to connect as a client via the nautilus. Mounting via the mount direct command still was working. I had to change the smb.conf file as suggested above by adding

client use spnego = no

Then you have to restart the samba network stack (just reboot).

Everything is working now.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.