1

Every time I log in I have to type "sudo rmmod acer_wmi" to get wifi to work. How do I get this to run on startup or permanantly delete acer_wmi.

Thx

  • Your driver found and loaded firmware and created an interface: wlp8s0. Is the switch or key combination set to enable wireless? rfkill list all? What is the trouble you are having specifically? – chili555 Apr 18 '16 at 20:45
  • Please run the network diagnostics and edit your question to include a link to the result. – David Foerster Apr 18 '16 at 21:48
4

Edit the blacklist:

sudo vi /etc/modprobe.d/blacklist.conf

And add the faulty module there (at the end):

blacklist acer_wmi

reboot and voilà

1

You can blacklist that module. It is convenient to make a separate file. Run in terminal:

sudo tee /etc/modprobe.d/blacklist-acer-wmi.conf <<< "blacklist acer_wmi"
1

​I realize I'm replying to this question rather late, but there's another method I've used when booting into liveUSBs. Since there is no easy way to edit their /etc/modprobe.d/ after creating the USB, add this snippet when you see the kernel selection screen add this by pressing [tab]

modprobe.blacklist=acer_wmi

Whether this gets carried over from the liveUSB to the distro once it's been installed can be hit or miss. If it doesn't, adding this parameter to /etc/default/grub on the line containing GRUB_CMDLINE_LINUX_DEFAULT=

Now every time you boot it'll be blacklisted!

I'm not always the best at explaining things like this so if you need clarification please let me know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.