I need help here. I just install ubuntu desktop 11.10 and can't get my wireless card work. it is based on RALink chipset.

I've found a link pointing to a driver: http://suporte.dlink.com.br/suporte/index.php. but it seems that this driver doesn't include data for a kernel 3.x compilation, only 2.4 and 2.6 :(

can somebody help me?


After have removed and reinstalled the card into the machine, Ubuntu starts to recognize the card as a RALink at least. But RT61pci default driver didn't work. The network get the status of UNCLAIMED:

 *-network UNCLAIMED
   description: Network controller
   product: RT2561/RT61 rev B 802.11g
   vendor: Ralink corp.
   physical id: 2
   bus info: pci@0000:03:02.0
   version: 00
   width: 32 bits
   clock: 33MHz
   capabilities: pm cap_list
   configuration: latency=32
   resources: memory:d0500000-d0507fff

So after have tried dozen of times to build the linux driver from DLink support site, I gave up and have tried with Ndiswrapper.

I discover that I need to use a 64bit driver and the only one that worked was the XP64 that I found here.

Now its getting better because I can see more things with iwconfig:

wlan0     IEEE 802.11g  ESSID:"dlink"  
      Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
      Bit Rate:54 Mb/s   Tx-Power:20 dBm   Sensitivity=-121 dBm  
      RTS thr=2347 B   Fragment thr=2346 B   
      Power Management:off
      Link Quality:0  Signal level:0  Noise level:0
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:0   Missed beacon:0

but I still can't connect to AP :(

lspci -nnk:

03:02.0 Network controller [0280]: Ralink corp. RT2561/RT61 rev B 802.11g [1814:0302]
Subsystem: D-Link System Inc AirPlus G DWL-G510 Wireless Network Adapter (Rev.C) [1186:3c09]
Kernel driver in use: ndiswrapper
Kernel modules: rt61pci

rfkill list all :

returns nothing.

sudo lshw -class network :

   description: Wireless interface
   product: RT2561/RT61 rev B 802.11g
   vendor: Ralink corp.
   physical id: 2
   bus info: pci@0000:03:02.0
   logical name: wlan0
   version: 00
   width: 32 bits
   clock: 33MHz
   capabilities: pm bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ndiswrapper+netrt61g driverversion=1.56+D-Link,06/12/2009, 1.02.08. latency=32 link=no multicast=yes wireless=IEEE 802.11g
   resources: irq:21 memory:d0500000-d0507fff
  • @fossfreedom, I've updated with your info. thanks – Cristiano Nov 5 '11 at 21:15
  • hmmm - that's very strange - it should be recognised right out of the box. Is this a firmware issue? what is the output of dmesg | grep -i firmware or possibly dmesg | grep -i phy - there should be something in the kernel logs showing what happens when its loading the network. – fossfreedom Nov 5 '11 at 21:39
  • :( yep... it is strange. the dmesg returns this : [ 0.396231] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored – Cristiano Nov 5 '11 at 22:02
  • I already have tried to add ath5k and ath9k to the blacklist, but nothing changes... – Cristiano Nov 5 '11 at 22:05
  • I really dislike saying this... but if the dmesg doesnt show anything about why the network isnt being recognised, you might have to download the win xp driver, extract the .inf and use ndiswrapper :( – fossfreedom Nov 5 '11 at 22:39

just confirmed... R2x00 package (RT61pci module) doesn't work with 64bits environments.

At least I have tested with Ubuntu 10.04 and 11.10, both server and desktop and I have tried with Debian Squezze 64 too.

They recognize the card, but the driver just don't work.

I have tried to compile it against the 64bit distrib, but didn't work either.

I've installed the 32bits version and the network manager works perfectly, out of box. :(

| improve this answer | |
  • well done for perservering on this +1 – fossfreedom Nov 10 '11 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.