12

I cannot login into locked Ubuntu 14.04 session Unity.

Output from /var/log/auth.log:

Apr 18 15:10:45 trusty-1 unix_chkpwd[3171]: check pass; user unknown
Apr 18 15:10:45 trusty-1 unix_chkpwd[3171]: password check failed for user (martin)
Apr 18 15:11:02 trusty-1 dbus[660]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.13" (uid=0 pid=1328 comm="lightdm ") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.67" (uid=1000 pid=2154 comm="/usr/lib/x86_64-linux-gnu/indicator-session/indica")
Apr 18 15:11:02 trusty-1 lightdm: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Apr 18 15:11:02 trusty-1 lightdm: PAM adding faulty module: pam_kwallet.so
Apr 18 15:11:02 trusty-1 lightdm: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Apr 18 15:11:02 trusty-1 systemd-logind[871]: New session c5 of user lightdm.
Apr 18 15:11:03 trusty-1 lightdm: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Apr 18 15:11:03 trusty-1 lightdm: PAM adding faulty module: pam_kwallet.so
Apr 18 15:11:03 trusty-1 lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "martin"
Apr 18 15:11:12 trusty-1 lightdm: pam_unix(lightdm-greeter:session): session closed for user lightdm
4
  • the file does not exist. but I don't use KDE. My desktop runs on Unity instead.
    – Martin
    Apr 18, 2016 at 13:46
  • I tried it: sudo apt-get purge kwalletmanager sudo apt-get install kwalletmanager. Lot of files installed. Reboot after that. But the problem still remains.
    – Martin
    Apr 18, 2016 at 14:10
  • A work-around is the following: from the locked screen choose "switch user" --> use similar dialog for entering password --> unlock screen
    – Martin
    Apr 18, 2016 at 14:28
  • I had this problem and solved following the answer of this other question: unix.stackexchange.com/a/422556/3084
    – brandizzi
    Jun 1, 2018 at 1:01

4 Answers 4

8

I solved by installing libpam-kwallet4 libpam-kwallet5 .

$ sudo apt-cache search kwallet |grep pam
libpam-kwallet4 - KWallet (KDE 4) integration with PAM
libpam-kwallet5 - KWallet (Kf5) integration with PAM
$ sudo apt-get install libpam-kwallet4 libpam-kwallet5
$ sudo service lightdm restart
1

Your log suggests that there is a problem with /lib/security/pam_kwallet.so. Can you determine if that file still exists, you may have to reload the kwallet:

sudo apt-get purge kwalletmanager
sudo apt-get install kwalletmanager
2
  • he file does not exist. but I don't use KDE. My desktop runs on Unity instead.
    – Martin
    Apr 18, 2016 at 13:47
  • 2
    sudo apt-get install --reinstall kwalletmanager would be enough to re-install missing files and doesn't remove configuration files like purge. Apr 18, 2016 at 15:48
1

Rebuild the pam authentication settings. Go to another TTY CTRL-ALT-F1, then run:

sudo pam-auth-update
# Make no changes and select "Ok" to update the config
sudo service lightdm restart
1

with showing up

$ sudo apt-cache search kwallet |grep pam

and whatever pam-kwallet version being used, but please use the version with your desktop manager's support compatibility.

following by https://ubuntu.pkgs.org/20.04/ubuntu-universe-amd64/libpam-kwallet5_5.18.4.1-0ubuntu1_amd64.deb.html

libpam-kwallet5 that is installed is right here...

$ ll /lib/x86_64-linux-gnu/security/pam_kwallet5.so

so just link'ing up this pam_kwallet5 to your asked /lib/security/pam_kwallet.so system path.

here is command might you need to run at,

$ sudo ln -sf /lib/x86_64-linux-gnu/security/pam_kwallet5.so /lib/security/pam_kwallet.so

then try to restart service that might you have to be..

$ sudo service lightdm restart

if $ journalctl -xe error still showing up, mybe ther's /etc/securetty not found, any other or permission failure just run mkdir and give chown 644 on it

$sudo sh -c "mkdir /etc/securetty && chown 0644 /etc/securetty"

and again, test it. happy solving

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .