1

Ok, so the clock in the top right corner of the menubar is going missing. Here's what I know:

  1. I'm on the 4/12/16 build of 16.04.

  2. The clock is present when I first install the OS. Even when it's gone now in my user account, it is still present in the guest account and at the login screen.

  3. The clock settings option in Settings -> Time & Date is grayed out, can't interact with it at all.

After much experimentation, I discovered that the issue is probably related to my installation of the applications I was using in 15.10. I have shell scripts written to restore everything I have.

After installing items individually, and rebooting after each one to try and see what the cause was, I have confirmed my suspicions that it's related to my installation of PlexMediaServer. I am including the bash script I ran for this installation below.

To install Plex, I first get the installer from the web and run it. Afterwards, I copy over my backed up metadata from an external drive and set permissions on it. Then, because all my media is on an external drive, I need to mount it in a separate folder so I can change permissions so Plex can see it.

I feel like the folder mounting is the most likely point to be the source of the issue, but I'm not sure. Including the bash script below. Any advice would be appreciated.

# Variables
MEDIA="MyPassport"
BACKUP="Seagate Expansion Drive"
EXTERNAL_PLEX="/media/craig/Seagate Expansion Drive/Plex Media Server"
INTERNAL_PLEX="/var/lib/plexmediaserver/Library/Application Support/"
LIST="/usr/share/gnome/applications/defaults.list"
MEDIA_DRIVE="/media/craig/MediaDrive"

# Special function for installing and configuring Plex.
function install_configure_plex {
    # Install Plex Application
    dpkg -i "$PLEX_FILE_NAME"

    # Stop the service to configure its settings
    service plexmediaserver stop

    # Restore meta data from backup
    echo "Copying Plex Media Server MetaData Backup. This may take some time."
    rm -rf "$INTERNAL_PLEX/Plex Media Server/"
    rsync -a --info=progress2 "$EXTERNAL_PLEX" "$INTERNAL_PLEX"
    chown -R plex:plex "$INTERNAL_PLEX/Plex Media Server/"
    rm "$PLEX_FILE_NAME"

    # Setup the media Hard Drive so that Plex can read from it.
    echo "Configuring Mount for Media Drive. Please wait."
    DEV_DRIVE=$(sudo blkid -L "My Passport")
    UUID=$(sudo blkid -o value -s UUID "$DEV_DRIVE")
    umount "$DEV_DRIVE"
    mkdir "$MEDIA_DRIVE"
    echo "UUID=$UUID $MEDIA_DRIVE ntfs-3g defaults,nofail,permissions,auto 0 1" | sudo tee -a /etc/fstab
    mount $MEDIA_DRIVE
    chown -R craig:plex $MEDIA_DRIVE

    # Start Plex
    service plexmediaserver start

    # Refresh Plex Libraries
    echo "Refreshing Plex libraries"
    export LD_LIBRARY_PATH=/usr/lib/plexmediaserver
    wget http://127.0.0.1:32400/library/sections/2/refresh
    wget http://127.0.0.1:32400/library/sections/1/refresh

    # Add plex values to environment variables
    echo "Adding Plex environment variables"
    echo "export PLEX_HOME=/var/lib/plexmediaserver/Library/Application\ Support/PlexMediaServer" >> ~/.profile
    echo "export LD_LIBRARY_PATH=/usr/lib/plexmediaserver" >> ~/.profile

    return 0
}

echo "Downloading Plex Media Server"
cd ~
PLEX_DL_URL=$(curl -s https://plex.tv/downloads | grep Ubuntu64 | cut -d\" -f2)
PLEX_ERROR=$(wget "$PLEX_DL_URL" --no-check-certificate 2>&1 >/dev/null)
PLEX_FILE_NAME="${PLEX_DL_URL##*/}"

# Verify that the Plex file downloaded properly before proceeding
if [ -f "$PLEX_FILE_NAME" ]
    then
        echo "Installing Plex Media Server"
        PLEX_DL_STATUS="success"
        install_configure_plex
    else
        printf "${RED}Error! Plex Media Server failed to download{NC}\n"
        printf "${RED}$ERROR${NC}\n"
        PLEX_DL_STATUS="fail"
fi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.