4

Weirded out owner of the first convergence device here.

I bought a bluetooth keyboard and mouse the day the tablet showed up in the mail. The tablet is engineered to be used that way, right? Pairing, check, desktop mode, check. Open some webpage to see how everything works. "Please enter email address and password" (I must have been on facebook or something)... Epic fail: I can't type the character "@".

On a standard German layout, the "@" sign is reached with the combination of "alt gr" and "Q". There are plenty of characters that can only be reached through "alt gr": "{ ,[ ,\, ~, |".

Since then, I also found out that none of the dead keys work. To make a "ê", I'd type "^" then "e". Typing "^" doesn't do anything. Typing "e" afterwise does a regular "e". Same with every other accents and non-ascii characters that the non-anglosaxon world absolutely needs to communicate. I mean, I started writing an email in French to my mom and stopped after a while and finger-typed it on the screen, because the unaccented version didn't make any sense.

I could spend a few hours remapping the keyboard, but the "keyboards" utility we've all been enjoying since the night of the age doesn't seem to exist in Ubuntu Touch, and has been replaced with a 3-options-menu.

Before you mention it, that 3-options menu doesn't let you pick a "compose" key. And, while we're at it, I did select the correct keyboard layout. All keys produce the expected character, except the dead keys and the ones that require "alt gr".

The keyboard itself is not at fault. I paired it with an android device, and it works as expected. I'm even typing with it right now! @ é è € {[]}

  • Unfortunately, I don't have a solution. I can only confirm that I have the same problem with an external BT keyboard (no affiliate link). Regardless of the layout I choose, the right Alt (or AltGr) key doesn't work, making it impossible to access characters that need this key combination. I am also having problems with 'dead keys' (i.e. composing characters like " + u = ü) which don't seem to work with any layout I chose. – Jens Grivolla Apr 22 '16 at 14:04
1

Sounds like this bug, which is targetted to be fixed in the next over the air updated, OTA-12.

https://bugs.launchpad.net/bugs/1565236

| improve this answer | |
0

Are you saying that the "Germany" keyboard layout is not available on the tablet's options? What type of keyboard does the tablet believe it's dealing with?

To activate the accented ASCII character combinations, you usually have to go into the system settings and tell it explicitly which "compose" key to use. That's the key that signals to the system that you're about to ask for a combo to be treated as a single alternative character.

For example, if you want to combine CTRL + "^" + "e" to get "ê" -- then your "compose" key is CTRL. You have to tell the system that one of the CTRL keys is the start of a combo.

On Macs, it's set up by default, but on most of the Linuxes I've set up recently, there's no compose key configured until you select one yourself.

To do this on desktop Ubuntu, there's a help file with instructions, here: https://help.ubuntu.com/community/ComposeKey

I don't have the Aquaris tablet yet, so I can't give you explicit instructions on the tablet version, but I bet if you get your tablet into Desktop mode, you can apply those instructions to the tablet too.

| improve this answer | |
  • The keyboard layout is correct. When I type "qwertz", it doesn't come out as " qwerty". All keys produce their supposed characters, except for dead keys and the ones that require pressing "alt gr". I know about the compose key and how to set it up. I would if I could, but the keyboard utility you are referring to isn't available in Unity8. In Unity8 you get to pick a keyboard layout and that's it. – sitarane Apr 21 '16 at 6:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.