gnome-volume-control does not recognise external hardware. My headphones work nonetheless, but an external microphone does not. External microphones used to work, but at times were temperamental - I would have to login or logout with or without microphone plugged in.

I am running Ubuntu 10.04 LTS (Lucid Lynx) on an mSi U100 wind notebook with one Intel soundcard and trying to use a jack microphone which has worked previously. USB microphones have also been problematic.

I have done the basics:

  • Installed upgrades.
  • Checked nothing is muted.
  • Looked for the device on gnome-volume-control.
  • Tried using a different microphone that works on a friends computer.
  • Tested my microphone works when using a different computer.
  • Checked my soundcard can be seen (cat /proc/asound/cards).

I have done more complicated things:

  • I have tried playing around with settings in alsamixer. Nothing is muted. I can adjust "mic" and "internal mic" regardless of whether an external microphone is plugged in. I have the choice of input source from "mic", "front mic", "line" and "CD". I've played around changing this and it hasn't helped. I only have one CAPTURE option.

    • In gnome-sound-recorder I have the choice of line, microphone 1 and microphone 2. I have played around changing this option. None of these pick up sound from the external microphone. Microphone 2 is the microphone on my laptop which is bad quality.

    • In gnome-sound-recorder I have the choice of different profiles, and changing this has not helped either.

    • I have looked at gstreamer-properties but none of that seemed helpful.

I don't know if there a way to check if these external devices are being picked up. I would like to make an external microphone work. Please help!


My computer, compaq CQ45-118A, intel sound card.

Since ubuntu 10.04 to 11.04, I have added to /etc/modprobe.d/alsa-base.conf the following lines and worked for me:

options snd-pcsp index=-2

alias snd-card-0 snd-hda-intel

alias sound-slot-0 snd-hda-intel

options snd-hda-intel model=dell-m4-1

options snd-hda-intel enable_msi=1

options snd-hda-intel position_fix=1 enable=yes
  • You just made me very happy!! – Koffeehaus Mar 9 '12 at 23:11

I found a solution, and uploaded a screencast to YouTube.

  1. Install alsa-tools-gui package.
  2. Run hdajackretask.
  3. At the top, the Realtek analog codec will be already selected. In my case, it was Realtek ALC270.
  4. Pay attention to the left panel (Pin configuration). In my case, it showed only 3 connected pins: Internal Mic, Internal speaker, Headphone. Note that it is missing a pin for the external microphone.
  5. Check: ☑ Show unconnected pins.
  6. Several new pins will show up at the left panel. For each one that is Not connected:
    • Check ☑ Override.
    • Look for a Microphone option at the drop-down box.
    • If there no Microphone in that box, then uncheck ☐ Override and try the next pin.
    • If there is a Microphone option, select it, and go to step 7.
  7. You should now have one pin that was previously unconnected but now is overridden as a microphone. Click on Apply now and enter your password.
  8. If you receive an error message about Device or resource busy, close any applications that are using the sound card (e.g. close alsamixer).
  9. If you receive a success message: Ok, now go ahead and test to see if it actually worked!, do what it says and test it!
  10. If it worked, click on Install boot override and enter your password again. If it did not work, uncheck ☐ Override and go back to step 6.

In my case, overriding pin 0x18 to Microphone fixed the issue for me.

  • I tried it but it didn't worked for me :( – Lokesh May 27 '17 at 9:28
  • Worked for me on 18.04, thanks! – Santiago Sep 11 '18 at 4:34

The only solution to make microphone work is to install linux-backports-modules-alsa-generic.

Just go to:

Menu > System > Administration > Synaptic Package Manager

And search and mark for installation:


Tip: if you have multiple versions click on the first and read the description which should inform what name to install.

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.