27

I am aware that the shortcode of "Shift + Alt + F12" disables all the desktop effects of Kubuntu 15.10. However, is there a way to disable all those effects automatically and permanently in every future session?

Objective: Speeding up Kubuntu 15.10 as much as possible.

  • This question is relevant to me because for some reason the autocomplete prompt in IntelliJ idea is also influenced by the fade effect... which is really distracting. I had to disable Fade in Desktop Effects. – xji Jan 28 '18 at 17:53
28

Head to

System Settings > Hardware > Display and Monitor > Compositor

Remove ✔ mark from Enable compositor on startup

When this is done, make reboot.

  • +1 - Thank you for your great answer! That indeed is the best way around it. – Ken Apr 17 '16 at 10:54
  • 1
    I don't think a reboot should be necessary... – AstroFloyd Nov 12 '17 at 9:37
  • It's not necessary in KDE Plasma 5.16 – Artur Tagisow Sep 20 at 19:52
7

EDIT: this answer is for KDE 4 - not 5

This can be done from:

System Settings > Workspace Appearance and Behaviour > Desktop Effects > General > Activation

A screenshot to show the menu:

enter image description here

And a lot of options in there to selectively block the effects so you don't miss out on all of the fun :)

  • Thank you for your answer. I didn't manage to find "Workspace Appearance and behaviour" option in the settings but i found the "Desktop Effects" entry. Are those two windows almost identical? (Please check this screenshot for clarification: i.imgur.com/KbIKLvx.png). Note: I have installed the KDE desktop environment after installing Ubuntu Mate, so my current installation is not a fresh installation of Kubuntu 15.10. – Ken Apr 17 '16 at 8:05
  • That looks like the 'All Effects' tab from my screenshot. Odd... – andrew.46 Apr 17 '16 at 8:51
3

In openSUSE Leap 42.2 , to turn off desktop effect. click settings > configure desktop> scroll down to display and monitor> compositor...un-click enable compositor on start up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.