8

I have a bone stock XPS13, ubuntu 14.04

I cannot figure out why my super key refuses to open dash. Alt works for shortcuts, super + w works for 'expose' and i used a keyboard tester to ensure all my buttons work.

  • I tried to set the 'search' keyboard shortcut in Ubuntu Settings, however it keeps reverting to 'disabled'
  • I downloaded ccsm, I tried to set it from there however it keeps clearing to nothing.
  • I downloaded unity tweak tool, and tried to set the dash shortcut, however it keeps reverting to blank.
  • I used ccsm to reset unity's settings, however this changed nothing.

I was able to map the 'show keyboard shortcuts' to z. However, this doesn't pull up the window, it only puts numbers on my docked applications. I cannot use z + num or super + num to get the docked apps to launch. Almost all, custom unity shortcuts based off of super dont work (except super + w oddly) I dug around dconf, I tried erasing my dotfiles in ~/ to no avail.

I feel I am at my last wits before wiping my computer and installing and compiling the Dell fixes for skylake manually. Does anyone know anything else I can try? Most other people had their problems solved by answered questions on this site and on various forums however none worked for me, in fact, my use case is slightly unique in that it keeps self disabling the key mapping once it's set.

Update

I found this question, where they suggest uninstalling the dell-super-key package. This is for the Dell Precision however.

mikey@mikey-XPS:~$ sudo dpkg -S dell-super-key
[sudo] password for mikey: 
dell-super-key: /usr/share/doc/dell-super-key/changelog.gz
dell-super-key: /usr/share/doc/dell-super-key/copyright
dell-super-key: /usr/share/glib-2.0/schemas/41_dell-super-key.gschema.override
dell-super-key: /usr/share/doc/dell-super-key

I do have it installed, I'm open to removing it if I can easily reinstall it. It doesn't have any man pages included so I have to find a way to determine if this is causing it to be disabled.

  • 1
    Possible duplicate of Super key not opening Dash – wjandrea Apr 17 '16 at 0:07
  • Thank you, but I saw that question, I tried with Unity tweak tool at that same setting and it resets once I bind the key. – mikeymop Apr 17 '16 at 0:09
  • Yes, I know. I flagged because you didn't mention if you tried the "Additional Drivers" solution. – wjandrea Apr 17 '16 at 0:12
  • Sorry, I did open the utility, thinking perhaps it could be triggered by the launching of the program. However, I dont have nvidia graphics, I have a skylake i5 using the igpu – mikeymop Apr 17 '16 at 0:19
  • Install xdotool and let me know if xdotool key Super works from terminal, ok ? If so, we can create custom shortcut for you – Sergiy Kolodyazhnyy Apr 17 '16 at 1:38
13

It appears the package dell-super-key is the culprit. I presume there is a hotkey combination to disable the super key on Windows and Dell wrote a shim to extend this functionality to the dev edition.

I however, cannot find any key combination that I could've pressed to clear the lock.

EDIT:

Oddly enough this is intended behavior.

mikey@mikey-XPS:~$ apt-cache search dell-super-key
dell-super-key - Disables the super key by default.

I found (dpkg -l) and emailed the package maintainer, Dell is legally required to include this package on their sputnik devices. It is safe to remove, and can be reinstalled from the recovery partition.

  • 1
    Did they say why they are so required to install this, and not warn their users who will all be expecting it? – neuronet Jun 3 '16 at 2:31
  • 4
    "Licensing issues" – mikeymop Jun 3 '16 at 2:49
  • If this was Windows people would be freaking out... – neuronet Jun 3 '16 at 4:01
  • I'm surprised they didn't put an Ubuntu Logo on to avoid this. Pretty sure "Start" is trademarked – mikeymop Jun 3 '16 at 4:14
  • 1
    lol good idea....probably would violate a different license to change the dell keyboard. :) – neuronet Jun 3 '16 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.