2

Krusader will not open gzip archives. Krusader claims it will "transparently handle" gzip, zip and some other archives. I tested a zip archive and Krusader does open the archive and shows the contents; I can browse the zip archive. However, when I try to do the same with a gzip archive, I get a pop up window inviting me the select which program to use to open the archive. It will not open the gzip archive even though it claims that it can and will.

Does anybody know why? I see the Krusader forum is closed due to spamming. Thanks for any help :)

I created the test archive using gzip from the command line and then used the file command to check the file type.

$ file  youtube-bowie-13-1-2016.txt.gz
youtube-bowie-13-1-2016.txt.gz: gzip compressed data, was "youtube-bowie-13-1-2016.txt", last modified: Thu Jan 14 12:19:15 2016, from Unix

Krusader Archive Handling

Krusader Pop Up

About my system:

Ubuntu version: 15.04

Krusader version: 2.4.0-beta3

  • 1
    Vivid Vervet 15.04 has reached 'End of Life' in February of this year. You will need to upgrade and then see if the issue persists... – andrew.46 Apr 17 '16 at 0:35
  • yes, I see that andrew. I am waiting for ubuntu 16 at the end of this month. yes, I will as you suggest wait and see. seems to me this is a long term trouble for krusader in ubuntu; finger's crossed for the upgrade anyhow :) – Randy Skretka Apr 17 '16 at 1:10
  • Looks like you will encounter the same issue unfortunately, workaround below... – andrew.46 Apr 18 '16 at 4:35
2

Although you question deals with an EOL Ubuntu release I have found that the same issue exists on Trusty Tahr. A partial fix is simple:

  1. Right click on the archive from within the Krusader winder
  2. Select: Other
  3. Select 'Browse'
  4. Navigate to /usr/bin/file-roller and select this
  5. Ensure you have selected the 'Remember Application...' button
  6. Click OK

A screenshot below to illustrate the crucial settings:

enter image description here

You will still not see the gzip file in the Krusader window (the 'Transparent' handling) but you will see it in File Roller. Annoyingly looks like that bug was actually closed as fixed in this version:

  • Thank you much for the workaround Andrew. I will be using that. I will accept your solution as I don't forsee a solution in a reasonable time. – Randy Skretka Apr 18 '16 at 20:44
1

I encountered similar problem with zip archives - despite "zip" options checked in "Archives" configuration tab and zip/unzip programs recognized automatically and available in $PATH, zip archives were not handled by Krusader but opened in external program.

The solution was to add MIME type "application/zip" to "krarc" protocol in "Protocols" configuration tab. This entry should be present but mysteriously disappeared.

  • Worked here for 16.04. – Murphy Sep 2 '16 at 9:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.