0

I have Lenovo Y700 with Nvidia GeForce GTX 960M and Ubuntu 15.10 running in VirtualBox.

I can't get my graphical card working under Linux.

I have installed:

  • nvidia-361
  • nvidia-opencl-icd-361
  • nvidia-prime
  • nvidia-settings

In VirtualBox 3D acceleration is enabled. Yet if I run:

lspci -k | grep -A 2 -E "(VGA|3D)"

I get:

00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter

Which I take means that Linux doesn't see my card? Also since installing the nvidia-* drivers Cinnamon crashes on startup (I assume this is connected with the same issue).

I tried to follow the arch-wiki and a few related answers here, but nothing seems to work (and/or seems outdated).

1

I might be wrong but I think even with 3D acceleration VirtualBox uses its own graphicscard in the VM. I think it's not possible to put your GeForce through!

  • Thank you for the pointer. The story is pretty complex - currently access via PCI passthrough might be possible for some kernels and cards, but the whole thing seems experimental at best... so I think I'll have to leave it as it is. – user673592 Apr 18 '16 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.