0

I was using Fedora linux and my hard drive crashed. I paid to have the hard drive recovered to a portable drive (name is passport). I scrapped the previous computer (it was getting old and annoying to update Fedora) so now I am using Ubuntu linux. When I plug the portable drive in, I think the mount is automatic. But, when I

  1. tried to use the command line at /media/whatever/markleeds to see the actual data, I got "access denied".
  2. tried to use the file manager and click on a directory or copy a directory to my actual hard drive, I get "error copying whatever". Click for more details says "access denied".

They told me that they used the ext4 file format but I cannot figure out why I can't get access. sudo cd doesn't work because it seems that you have to create shell first? The owner is 1000 which may be the source of the problem.

If they used the wrong file format by accident, would that cause the access problems? Thanks for any tips, pointers. The company I am using is trying again with the hope that something was done incorrectly the first time.

Is it safer to recover using say NTFS or something else and then converting to ext4?

1

Have you checked files permissions? You can recursively update those with this:

sudo chmod -R 744 /media/whatever/markleeds

This will give you ALL possible permissions for all files and folders there and read access to group and others.

Explanation of the octal triple:

(7)(4)(4)
|  |  |
|  |  (others) read only
|  |
|  (group) read only
|
(user) read, write and execute

The octal numbers are summed up to reflect the files permissions where in that example for the user:

(4) read access + (2) write access + (1) execute permission = 7 

And here's how you change owner recursively:

sudo chown -R markleeds:markleeds /media/whatever/markleeds
5
  • thanks. I tried variations of what you mentioned but even after doing those things, I still couldn't get in. But I may have used some variation that was slightly different. when I get baclkthe second attempt, I'll see if those work. thanks. – mark leeds Apr 16 '16 at 3:10
  • -1 for chmod 777. – muru Apr 16 '16 at 8:44
  • What's wrong with 777? If you are the only one using this media, it should be fine... You can always run your own, safer rule, this should also be ok sudo chmod -R 755 /media/whatever/markleeds/*, I'm only not sure how to do it recursively without execute permission... Oh, and I got one more hint: check permissions for all directories before drive's root, like /media/whatever, /media, etc. One might not be accessible. – GreggD Apr 16 '16 at 12:05
  • funny thing i get past /media/whatever where wherever is a bunch of numbers. but when I get to /markleeds is when the access problem happens. they said that they used ext4 for the format which seems like the right thing. they are going to try again and then when I get it back, I'll see if I can get in this time. – mark leeds Apr 17 '16 at 3:26
  • I think if it would be different filesystem, it wouldn't mount properly. Personally I would try data recovery software (like R-Linux - it's the best), it might be able to detect what they did and get around it, however it's a little stupid to have to recover data that's already suppose to be recovered :) – GreggD Apr 17 '16 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.