2

I have setup my ubuntu machine to allow remote connections using the default "Desktop Sharing Preferences" panel, and then I used Mac's VNC viewer Share Screens to connect to it, and it works.

However, it doesn't connect to the current open session in the machine, it creates a new one, which it will then keep using everytime I connect (but if I log in person to the machine, I get the other session, the original one).

This means I can't see/use the windows that I was working with, and some apps like Firefox won't even let me open them, since they say an instance of the program is already open.

Is there a way to VNC directly into the existing/current session instead of creating a new one?

Edit:

This is are my settings: Desktop Sharing Preferences

  • 1
    What VNC server software are you using on Ubuntu? The default 'Desktop Sharing' (aka vino-server) should do exactly what you describe. – steeldriver Apr 15 '16 at 19:30
  • Yeah I'm using the default remote app I'm Ubuntu, and just configuring it to always accept incoming connections with a pin – Francisco Noriega Apr 15 '16 at 19:31
  • Does vino-server use the tightvnc-like method of starting a new X display? @FranciscoNoriega Do you have both the Allow other users to... checkboxes checked? – UniversallyUniqueID Apr 16 '16 at 7:29
  • @BharadwajRaju, I'm not sure about the first question, regarding the one addressed to me, yes, I have both checked. I've updated the original question with a screenshot of my settings too. – Francisco Noriega Apr 16 '16 at 21:42
  • @FranciscoNoriega Could you try x11vnc and see? It requires more manual configuration, but it works. – UniversallyUniqueID Apr 17 '16 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.