2

I am have a remote machine behind a firewall that I wish to connect to through SSH. As far as I understand this can be achieved by using a reverse ssh tunnel.

So the command I am using is

ssh -N -f -R 0.0.0.0:1234:localhost:22  -i /home/username/.ssh/id_rsa.pub  username@remote-server.com

My main problem is that I want to execute this command whenever the computer starts so that the computer is accessible after a reboot.

I tried to use cron by adding the command both my user's crontab and in /etc/cron. However the problem I have is that both commands are asked for a password. I have created the id_rsa.pub file and sent it to the remote-server but still it does not seem to work.

If I am logged in (e.g. through teamviewer) I can run the command and no password is asked. If I run the command as root (sudo) the (empty) password for the rsa file is asked. I suspect that my problem is here, i.e., when cron executes the command ssh asks for the password and the command hangs.

I have tried using both my user's rsa file and the root's rsa file and with none of them I manage to connect.

2

Just add sleep 60; before your ssh command:

@reboot sleep 60;ssh -N -f -R 0.0.0.0:1234:localhost:22  -i /home/username/.ssh/id_rsa  username@remote-server.com
after reboot your network is still down
1

Fixing SSH problem

You can't authenticate remote machine with public key, you need to use private key to do that. Public key has to be at remote server. If you're not sure, then just copy public key to remote server like that:

ssh-copy-id -i ~/.ssh/id_rsa.pub username@remoteserver

and then run your command with private key:

ssh -N -f -R 0.0.0.0:1234:localhost:22  -i /home/username/.ssh/id_rsa  username@remote-server.com

Running this command at boot-up

As you went already with crontab then run crontab -e to edit your cron. Add following line to execute that command once your computer boots up.

@reboot ssh -N -f -R 0.0.0.0:1234:localhost:22  -i /home/username/.ssh/id_rsa  username@remote-server.com
  • 2
    the command works if I run it manually. It does not run when I try to run it automatically. – orestis Apr 22 '16 at 16:47
  • I had the same problem, adding sleep 60 as described above solved it. – Nickpick Dec 5 '17 at 20:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.