2

I'm trying to install mongodb on ubuntu 15.10. While following this - Install Mongo 3.2 on Ubuntu 15.10 - i got the following error message:

W: GPG error: http://repo.mongodb.org trusty/mongodb-org/3.2 Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY D68FA50FEA312927

So then I attempted to add the key like this:

me@devbox:/etc/test$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys D68FA50FEA312927

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.CWnpUGSg5w --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/apt.postgresql.org.gpg --keyring /etc/apt/trusted.gpg.d/nginx_ubuntu_stable.gpg --keyring /etc/apt/trusted.gpg.d/webupd8team_ubuntu_java.gpg --keyserver keyserver.ubuntu.com --recv-keys D68FA50FEA312927
gpg: requesting key EA312927 from hkp server keyserver.ubuntu.com
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

Not sure what else to try. I'm currently looking other posts here on this site to see if this has been addressed.

EDIT 1:

Based on this post: Can't add repo keys

I tried to run the command :

sudo gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys D68FA50FEA312927

and then retried:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys D68FA50FEA312927

But it's still failing.

  • sudo apt-key adv --keyserver-options http-proxy="http://<username>:<password>@<proxy_server_addr>:<proxy_port>" --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys <key_to_import> – Happydevdays Apr 15 '16 at 15:13
  • Your internet had problem and yiu can't see the key server . Please try with this refrence : digitalocean.com/community/tutorials/… If not solved . I suggest download mongodb .deb file from mongodb offical sites and install them from local – user3728800 Apr 15 '16 at 16:05
  • Are you behind a proxy? Can you reach keyserver.ubuntu.com with a plain TCP connection (telnet keyserver.ubuntu.com 80)? – David Foerster Apr 24 '16 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.