6

I got a new Huawei E3372 modem for my 4G data connection. I have not been able to make it work, since it does not show up in my Network Manager. Can some one point me to the correct direction on how to make it work. Here are the details of my hardware:

Machine: Lenovo X220

OS: Ubuntu 15.10

Modem: Huawei E3372

Output of command lsusb

Bus 002 Device 016: ID 12d1:14dc Huawei Technologies Co., Ltd.

Output of command dmesg

[ 6751.613272] usb 2-1.1: Product: HUAWEI_MOBILE
[ 6751.613276] usb 2-1.1: Manufacturer: HUAWEI_MOBILE
[ 6751.796901] cdc_ether 2-1.1:1.0 eth1: register 'cdc_ether' at usb-0000:00:1d.0-1.1, CDC Ethernet Device, 0c:5b:8f:27:9a:64
[ 6751.798113] usb-storage 2-1.1:1.2: USB Mass Storage device detected
[ 6751.798961] scsi host19: usb-storage 2-1.1:1.2
[ 6751.850055] cdc_ether 2-1.1:1.0 enx0c5b8f279a64: renamed from eth1
[ 6751.903291] IPv6: ADDRCONF(NETDEV_UP): enx0c5b8f279a64: link is not ready
[ 6751.903578] cdc_ether 2-1.1:1.0 enx0c5b8f279a64: kevent 12 may have been dropped
[ 6752.806483] scsi 19:0:0:0: Direct-Access     HUAWEI   TF CARD Storage  2.31 PQ: 0 ANSI: 2
[ 6752.807718] sd 19:0:0:0: Attached scsi generic sg1 type 0
[ 6752.815155] sd 19:0:0:0: [sdb] Attached SCSI removable disk
5

I first had to switch from mass storage to network mode (Ubuntu 16.04)

add the following to /etc/usb_modeswitch.conf

 # Huawei E353 (3.se) and others
 TargetVendor=0x12d1
 TargetProductList="14db,14dc"
 HuaweiNewMode=1
 NoDriverLoading=1

then run the actual modeswitching command

sudo usb_modeswitch -v 12d1 -p 1f01 -c /etc/usb_modeswitch.conf 

I sometimes have to run the modeswitch several times

|improve this answer|||||
  • Works, but I'd add this to a separate file instead: /etc/usb_modeswitch.d/huawei_e3.conf. – hudolejev Jan 16 '18 at 6:38
  • Note: for my Huawei E3372 I had to use TargetProductList="157d". You can find the needed number from lsusb output. – hudolejev Jan 16 '18 at 6:40
3

Since no one was helping here, I figured it our myself how to make it work. Its actually quite easy. When this device it connected run lsusb to check for the device id. It should be 12d1:14dc Huawei Technologies Co., Ltd.. If you see this device id on our machine that mean the modem has been registered successfully and can be used.

Add a new network connection using Network Manager panel. The connection type is 'Ethernet'. In Device Mac Address, select the mac address of your modem and click 'Save'. This new connection should come up in your Network Manager now. I hope this answer helps others.

|improve this answer|||||
1

Tojo's answer works! The USB dongle works directly as a "wired connection". However, I have to set the correct APN in the web interface on http://192.168.8.1/ Hope this small tips will help someone else.

|improve this answer|||||
0

Simon's answer helped me.
Additionally, I had to visit web interface, and click "Connect".
In case of my operator (Play (P4), Poland), I didn't have to configure other settings (APN was already correct: internet).

|improve this answer|||||
0

This is HiLink modem, that means no need for ppp, wvdial, ttyUSB, usb_modeswitch, fallback mode switching etc.

It's discovered as Enternet device (but in down state) - to list devices use commands:

ip link ls

or

ipconfig -a

such device is for example enx0c5b8f279a64, where hex after enx is MAC

now just use and that's it:

dhclient enx0c5b8f279a64

for persistent configuration add entry in /etc/network/interfaces (for debian)

auto enx0c5b8f279a64
iface enx0c5b8f279a64 inet dhcp

then start (if not started yet):

ifup enx0c5b8f279a64

or

ip link enx0c5b8f279a64 up

now check if present in routing table:

route -n

or

ip route

Tested using Polish PLAY network

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.