3

In my newly installed Ubuntu 14.04 LTS Suspend is not working. I tried to do it with sudo s2ram. I am getting a message

KMS graphics driver is in use, skipping quirks.

I also tried sudo pm-suspend with both of them the computer is going to sleep. When I press any button in the keyboard or the power button it woke up, but when it woke up, the screen freezes. I have tried some posts, but to no avail. I have added the links which I have tried.

Link 1, Link 2, Link 3

I always put my computer to sleep, but this problem has made using the computer practically impossible.

2

I have solved the problem by running

sudo apt-get install nvidia-current-updates

Now I can use suspend without any fuzz. I came across This post and my pc is working just fine. The nouveau driver it has some problem with the power management. Once the latest driver for the Nvidia is installed, it has solved the problem on it's own.

  • so you mean you can put your computer to sleep and wake it without any problems like screen freeze or black screen etc? – Edward Torvalds Apr 16 '16 at 11:01
  • Yes exactly. The problem I had is gone. Now it is possible to put the computer in sleep mode and then when I wake it up, It has all the program I had opened before I put it into sleep. And the screen does not freeze as well. – mr_azad Apr 16 '16 at 11:08
1

try to install pm-utils and suspend pc with pm-suspend command.

  • It is already installed and I have tried it before. But sudo pm-suspend does not work as well. – mr_azad Apr 15 '16 at 10:21
  • Is there any useful information in /var/log/pm-suspend.log? – Doug Smythies Apr 15 '16 at 14:50
  • @DougSmythies Hey, sorry for late reply. I have added the output of /var/log/pm-suspend.log please, take a look and help me if possible. – mr_azad Apr 15 '16 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.