2

I have installed Ubuntu 16.04 final beta on a Dell Inspiron 15 5000 Series (Intel(R)) - 5559. This laptop has a AMD Radeon(TM) R5 M335 4GB DDR3 GPU.

I am unable to tell if it is being used or not. Indeed, the open source drivers module seems to be loaded:

$> lsmod  | grep radeon
radeon               1511424  1
i2c_algo_bit           16384  2 i915_bpo,radeon
ttm                    98304  1 radeon
drm_kms_helper        139264  2 i915_bpo,radeon
drm                   360448  9 ttm,i915_bpo,drm_kms_helper,radeon

however, I expected to see it listed in lspci, while there only seems to be the integrated intel card:

$> lspci | grep -i graphic
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 07)

Also, I have installed the radeontop utility but it outputs:

Can't find Radeon cards

I don't know if it's relevant, but OpenGL seems to be working:

$> glxinfo | grep direct
direct rendering: Yes
GL_ARB_direct_state_access, GL_ARB_draw_buffers, 
GL_ARB_draw_indirect, GL_ARB_draw_instanced, 
GL_ARB_map_buffer_range, GL_ARB_multi_bind, GL_ARB_multi_draw_indirect, 

but still I don't know if it's the intel or the radeon card taking care of it.

I have never tried older versions of ubuntu on this laptop, so I have never tried the - now deprecated - proprietary drivers.

How can I tell if my graphic card is working? If it's not, how can I make it work again?

  • I have problems with AMD integrated graphics too. I'm using 14.04. The drivers are not OK. – NonStandardModel Apr 15 '16 at 10:26
  • 1
    I've just filed this bug bugs.launchpad.net/ubuntu/+source/linux/+bug/1570802 – Nicola Sap Apr 15 '16 at 11:22
  • I have graphics problems with the same GPU. The Linux kernel no longer supports the GPU. It appears that Debian/Ubuntu wrote a generic driver and it lacks full rendering. It still works. Toshiba sold this model, and I bought it off eBay for $40 new with a defect. Ubuntu 16.04 runs great on this machine. The original OS, Windows 7, could barely boot. I suggest moving to a better laptop with a newer generation CPU. Anyway, that;s my plan. – tom-adelstein Mar 24 '17 at 19:06
1

To tell if your card is working, do a xrandr --listproviders. Both cards should be visible.

If you want to use it, the best way is xrandr --setprovideroffloadsink radeon Intel, with it, you can use your discrete card for the applications who need it the most (for example games, 3D modellers...) by prepending the DRI_PRIME=1 environment variable:

DRI_PRIME=1 glxinfo | grep "OpenGL renderer" should give an output of OpenGL renderer string: Gallium 0.4 on AMD <platform>.

  • 1
    The first command outputs Could not find provider with name radeon, the second one reads Gallium 0.4 on AMD HAINAN (DRM 2.43.0, LLVM 3.8.0), but I'm not sure what does it mean! – Nicola Sap Apr 15 '16 at 9:22
  • Ok, the meaning of the prepended variable is clear now. So, I'm apparently able to make the GPU work. However, I've tried launching DRI_PRIME=1 blender and it is very unstable, making the whole system freeze. I'll file a bug report. I still don't know what I should have expected from the xrandr command, though. – Nicola Sap Apr 15 '16 at 10:05
  • The AMD support is laughable at the moment. I edited my answer to make it less confusing. – emk2203 Apr 15 '16 at 10:13
  • Ok so now I know how to make it work, but it works very bad. Anyway, your answer led me closer to the answer, so I'm accepting it. Thanks – Nicola Sap Apr 15 '16 at 10:22
  • 1
    @NicolaSap I have the exact same problem on the same hardware. Would you mind explaining more in detail what exactly you did to make it work, maybe in a separate answer to your question? That'd be awesome! – deesnook Feb 18 '17 at 9:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.