I've been trying to install Ubuntu GNOME for the past 7 hours, on my new ROG GL552. At the beginning, I couldn't even install it until I found this post:


I added the "nouveau.modeset=0 tpm_tis.interrupts=0 acpi_osi=! acpi_backlight=native i915.preliminary_hw_support=1 idle=nomwait" just before the --- part when editing the installation, and the installation ran smoothly.

After that, I couldn't boot into the system still because the same commands need to be added when booting, and it took me a little while to figure out where in the code I need to add them - since I'm pretty much a complete beginner.

After adding that line in the correct place, the system booted (although the touchpad functions are very limited) and I edited /etc/default/grub to contain the same commands.

I tried to keep following that forum post to try and understand how to make my Ubuntu work like it's supposed to - also with correct usage of my video card (gtx 960m), so I installed bumblebee and uncommented the nvidia driver section. rebooted the system and then the system doesn't boot yet again...

I really want to make Linux my main operating system but this really makes me want to give up. I don't understand half of the things I'm trying to do. I wanted to install the Ubuntu GNOME and really start learning Linux in and out but I can't even install it properly on this computer.

Does anyone have any tips? Any guide for a complete beginner on installing Ubuntu on this machine?

Thank you for any answer and I hope I can start using Linux

  • 2
    Bumblebee is out dated,. remove it and the driver sudo apt-get purge bumblebee nvidia* reboot, and install this driver sudo apt-get install nvidia-352, you can find the nvidia settings app in your applications and use that for multi gpu support. – Mark Kirby Apr 15 '16 at 7:15
  • Can I remove bumblebee from the grub on boot menu? Since after installing bumblebee I can't boot the system. I can always re-install everything I guess – Vollek Apr 15 '16 at 7:26
  • Use the recovery mode to get in to your Ubuntu and then run the commands wiki.ubuntu.com/RecoveryMode – Mark Kirby Apr 15 '16 at 7:30
  • That didn't quite load either. I'm re-installing everything and will do as you suggested. Could you tell me how can I check my whole system that it works correctly? (Drivers etc.) – Vollek Apr 15 '16 at 7:55
  • I don't understand "how can I check if the whole system works correctly?", you have to test them. There is a GUI called additional drivers that will tell you the current driver in use but except that all you can do is try it. – Mark Kirby Apr 15 '16 at 8:18

Bumblebee is deprecated, likely the guide you were following is outdated, the Nvidia drivers come with everything you need to manage your multi GPU laptop.

First remove any installed driver and Bumblebee

sudo apt-get purge bumblebee nvidia*

Now reboot

sudo reboot

Now install the latest Nvidia driver from the repository (if you can't reboot to Ubuntu use recovery mode)

sudo apt-get install nvidia-352

This includes nvidia-prime that you can use to control your GPU's, you can find it in the application nvidia-settings.

"how can I check if the whole system works correctly?"

As you mean check what drivers are in use, you can check the application additional drivers, this is preinstalled in Ubuntu Gnome.

  • 2
    You need to wrap nvidia* in quotes otherwise it will be expanded by the shell. – jcubic Oct 2 '16 at 11:36

I carried out a fresh install of 16.04 on my ASUS GL552VW.

The only additional GRUB parameters I entered (for installation and normal boot) were:


To stop Nouveau from taking over.

Once I'd installed the nVidia 361.42 drivers, through the Additional Drivers tab in Software Updater, I had to disable Secure Boot. (Secure boot stops unsigned kernel modules loading)

With those settings, everything works. Touchpad, Skylake support, nVidia graphics @ 1920x1080, Wifi, Bluetooth, keyboard backlight.

Installation of 16.04 is much less hassle than previous versions.

  • You sir ... saved my life. Done with those complicated options – Tamim Addari Jun 22 '16 at 14:59
  • Thanks for this post. To avoid hours of aggravation I have to second setting the nvidia drivers ASAP, otherwise you may need to use the grub recovery mode to get back in to do this. – user1592380 Sep 1 '16 at 15:01
  • This didn't work for me (16.04 on my ASUS GL552VW). I had to set acpi=off in order to boot the first few times, but after I installed the new video drivers then nouveau.modeset=0 was sufficient. – MasterHD Mar 7 '17 at 11:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.