3

I few months ago I did a fresh install of Ubuntu 15.10 on my laptop. I had backed up my previous home folder and restored it on top of my installation. I installed Google Chrome and set it as my default browser, but links would always open a new blank Chrome window, so I set Firefox as my default browser. Yesterday I was going to try setting Chrome back as my default, but the option does not show up.

![Details settings screen.]

Chrome's settings indicates it is already the default browser.

I have tried every method under the Internet's Sun to set Google Chrome as my default browser without success, starting with doing an uninstall purge of google-chrome-stable through apt, and then reinstalling from the latest deb.

Setting the BROWSER environmental variable.

$ tail ~/.bashrc
export PATH=$PATH:/home/david/Android/Sdk/tools
export VIRTUALENVWRAPPER_PYTHON=/usr/bin/python3
export WORKON_HOME=~/virtualenvs
export ANDROID_HOME=/home/david/Android/Sdk

export BROWSER=`which google-chrome`

Setting x-www-browser.

$ sudo update-alternatives --config x-www-browser
There are 3 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

  Selection    Path                           Priority   Status
------------------------------------------------------------
  0            /usr/bin/google-chrome-stable   200       auto mode
  1            /usr/bin/firefox                40        manual mode
* 2            /usr/bin/google-chrome-stable   200       manual mode
  3            /usr/bin/xlinks2                69        manual mode

Press <enter> to keep the current choice[*], or type selection number: 

Setting gnome-www-browser.

$ sudo update-alternatives --config gnome-www-browser 
There are 2 choices for the alternative gnome-www-browser (providing /usr/bin/gnome-www-browser).

  Selection    Path                           Priority   Status
------------------------------------------------------------
  0            /usr/bin/google-chrome-stable   200       auto mode
  1            /usr/bin/firefox                40        manual mode
* 2            /usr/bin/google-chrome-stable   200       manual mode

Press <enter> to keep the current choice[*], or type selection number: 

Updating xdg-settings

$ xdg-settings set default-web-browser google-chrome.desktop

However, the Details settings window still shows Firefox, and all links from GUI applications open in Firefox.

Edit: I've notice that in the GTK application picker, such as when you right-click a file and choose "Open With -> Other Application…" that Chrome is not showing up in the list. The .desktop file is in /usr/share/applications and I tried executing sudo update-desktop-database, but it still doesn't show up. It does show up in the Unity dash.

If I look in /usr/share/applications/mimeinfo.cache then I see it is registered for text/html, x-scheme-handler/http, x-scheme-hanlder/https, as well as others.

2

I discovered the source of my problem. The global location for .desktop files is /usr/share/applications/ The user specific location is ~/.local/share/applications. For whatever reason, there was a google-chrome.desktop file in that directory that did not have the MIME meta data setup correctly. Since the local file overrides the global file, Google Chrome wasn't recognized as a web browser. Once I deleted that file I could set Google Chrome as my default web browser and now links open in it correctly.

0

I have this problem sometimes, and for me a good solution is to open Ubuntu Tweak and then go to Admins > File Type Manager. There look for the file type "HTML document" and then you can change the Associated Application to Chrome.

  • I tried that, but links still open in Firefox. – David Baucum Apr 14 '16 at 18:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.