1

I'm still not sure of this will fix my printing problem, but I'm trying to revert my Java into a 32 bit version, after finding out my 64 bit Java doesn't communicate with CUPS. (Ubuntu 15.10 64 bit)

sudo apt-get install openjdk-8-jdk:i386

I now have a 32 bit Java. java -version returns

openjdk version "1.8.0_66-internal"
OpenJDK Runtime Environment (build 1.8.0_66-internal-b17)
OpenJDK Server VM (build 25.66-b17, mixed mode)

But i cannot seem to install OpenJFX for 32-bit

sudo apt-get install openjfx

or

sudo apt-get install openjfx:i386`

openjfx installs the 64 bit version, making it invisible to the 32 bit programs.

The following NEW packages will be installed:
  libgconf2-4 libopenjfx-java libopenjfx-jni openjdk-8-jre
  openjdk-8-jre-headless openjfx

openjfx:i386 requires a libopenjfx-java:i386 that "cannot be installed"

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 openjfx:i386 : Depends: libopenjfx-java:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

I tried sudo apt-get install libopenjfx-java:i386

Package libopenjfx-java:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libopenjfx-java:i386' has no installation candidate

sudo apt-get update was the first thing I did after reading the above, but I get the same response

This is my first time using :i386 and I have no idea what else I can do to make this work. Any ideas?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.