0

i have installed wine later tried instaling Zerdha trader (Nest) is opening but showing error, Pi is not at all opening.

  • Welcome to Ask Ubuntu! ;-) Could you please give us a bit more information by editing your question and telling us: what version of Ubuntu you're running? What the error message is? Please edit your question and add this information... (Please help us help you!) – Fabby Apr 14 '16 at 10:08
1

To install Zerodha Pi you need,

  1. Microsoft .NET Framework 4(x86 and x64)
  2. Microsoft Visual C++ 2008 Runtime Libraries(x86)
  3. Microsoft Visual C++ 2010 Runtime Libraries(x86)

Step 1 :

First of all Install wine and winetricks.

wine : using ppa for latest version.

sudo apt-add-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get install wine1.7

winetricks :

sudo apt-get install winetricks

Step 2 :

Most of the Windows apps work on 32 Bit. So you have to create a 32 Bit wineprefix by following commands,

rm -fr ~/.wine  
export WINEARCH="win32"
export WINEPREFIX=~/.wine/

Now you can install Microsoft .NET Framework 4.0 using winetricks as,

winetricks dotnet40

Step 3:

I suppose you have already downloaded Zerodha Pi from Zerodha q-back office with the activation key. Extract pi.zip in the Downloads directory and you will get a directory pi. There you can find Pi_setup.exe. Run the following command to install it,

wine ~/Downloads/pi/Pi_setup.exe

Before installing Pi you can see the system would install Microsoft Visual C++ 2008 and Microsoft Visual C++ 2010.

At last step Pi will be installed and a desktop icon will be created. Just Log in with your credentials, answer those two security questions. Then Pi will ask for the activation key. Just put it to activate. Happy Trading.


For more information please look at,

  1. Running .Net 4.0 application with Wine

  2. How to install and configure Wine?

  • I have tried it in Ubuntu 14.04 LTS today. Everything gets installed but, when I click on the Pi icon the program doesn't gets launched. Any idea what should look into? – Imdad Feb 22 '18 at 19:28
  • sorry @Imdad.. I struggled much to make this happen.. But could not solve this and switched to kite.. – ddas Feb 23 '18 at 6:31

protected by Community Feb 15 '17 at 10:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.