I am running Ubuntu 15.10 and have a laptop with NVIDIA Optimus technology. As known by many, Optimus has yet to receive official support and has a lot of issues. Since I do not need the power of the graphics card for when I am on Ubuntu I would like to know if it is possible to completely disable the NVIDIA card altogether and only use the Intel on-board graphics. How would I go about doing this if possible?

I know of one solution which is using the NVIDIA PRIME and changing the profile to only use Intel, but the problem with this is that using the NVIDIA driver causes severe screen tearing which is annoying to deal with so this is not an option for me.

  • Which laptop do you run? My Dell Latitude E6530 lets me disable nvidia in the BIOS. – emk2203 Apr 14 '16 at 4:41
  • @emk2203 I cannot disable the card through my BIOS and even if I could, I have a Windows partition which I use the graphics card. – JCCS Apr 14 '16 at 4:47
  • You could test-drive a live cd of 16.10, which is very close to release now. Hardware and graphics issues are often fixed in the latest version. In my experience, it's worth the risk on single-user laptops. – emk2203 Apr 14 '16 at 6:39
up vote 4 down vote accepted

Uninstall the proprietary NVIDIA drivers and disable the use of the nouveau drivers.

Open a terminal and execute :

sudo apt-get install gksu
gksudo gedit /etc/default/grub  

Add nouveau.modeset=0 to the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

so that it reads GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0".

Save changes and close the file.

Now execute these commands :

sudo update-grub  
sudo apt-get purge nvidia*  
sudo reboot  

Now you are using the integrated intel graphics and the NVIDIA graphics are not in use.

  • I had this problem: superuser.com/questions/1277651/msi-laptop-screen-freezing you think the problem is with nvidia? and removing the nvidia in this way(our answer) will solve my problem? @cl-netbox – Sss Dec 16 '17 at 15:22
  • @CnA I assume that there is something else wrong with your notebook, because when you installed the NVIDIA drivers correctly within Windows, it should just work fine in Windows ... you can try to install the proprietary NVIDIA drivers in Ubuntu to have a comparison. Please check your BIOS / UEFI settings, if everything is setup properly there and especially have a look at the configuration of NVIDIA Optimus. :) – cl-netbox Dec 16 '17 at 16:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.