5

I just installed Ubuntu on my laptop with a RTL8723BE adapter and the Wi-Fi is really spotty.

Sometimes available wireless networks won't even show up in the menu, and other times just the network in my household will show up and just barely function (I can ping, sites like Stack Exchange usually manage to load, etc.)

I saw online some people suggest in a terminal entering echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf and rebooting, but it didn't work.

I saw someone suggest updating the driver with:

sudo apt-get install build-essential git
git clone https://github.com/lwfinger/rtlwifi_new/
cd rtlwifi_new
make
sudo make install
sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

Rebooted, and it still didn't work.

I also found this, and it didn't work:

sudo add-apt-repository ppa:hanipouspilot/rtlwifi 
sudo apt-get update 
sudo apt-get install rtlwifi-new-dkms linux-firmware

I have no problems with Windows on this laptop. Do I just have to accept I can't use Ubuntu on it?

7

Does your installed version of the driver have this parameter?

parm:           ant_sel:Set to 1 or 2 to force antenna number (default 0)

Check:

modinfo rtl8723be

If so, I suggest that you do, in a terminal:

sudo -i
echo "options rtl8723be ant_sel=2"  >  /etc/modprobe.d/rtl8723be.conf
exit

Reboot. Is there any improvement?

  • This worked perfectly. Thank you so much! (P.S. There's someone with the same problem as me here if you'd like to give them a hand as well). – Whatever Apr 18 '16 at 21:15
  • Worked awesome, from 20kb/s to 1.5Mb/s without reboot/logout. – some user Apr 27 '17 at 21:10

protected by Community Feb 8 '18 at 10:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.