9

I'm about to config my new fantastic T460s with Ubuntu 16.04 (because of Skylake Kernel issue I've to chose such new version) I tried to use my fingerprint sensor which is 138a:0090 (lusb) Fingerprint Gui doesn't recognize the device which is no wonder, because it is not on the compatibility list of it. Do I've to wait for a driver or is there something I can do about this?

Thanks a lot :)

6
  • 1
    16.04 hasn't been released, which makes your question off-topic. If your question was about how to make that particular fingerprint reader work, that would be a different thing. – LiveWireBT Apr 12 '16 at 23:14
  • That's exactly my question, I'm new to this community as writer so please excuse some mistakes in posting stuff – Atomius Apr 13 '16 at 10:57
  • 1
    This is not supported yet, track the bug at bugs.freedesktop.org/show_bug.cgi?id=94536 – Treviño May 4 '16 at 15:26
  • I have the same scanner on my new Lenovo Thinkpad X1 Yoga. Also no luck with fprint. I looked at the libfprint repo, but the project was last updated in 2008, and there does not seem to be a "driver request list" :( – user549770 May 29 '16 at 0:50
  • this worked with my x1-carbon i7 3rd generation 3448 launchpad.net/~fingerprint/+archive/ubuntu/fingerprint-gui Best luck – Sherif Salem Jul 15 '17 at 9:38
8

I just got the finger print reader (138a:0090) working on my Thinkpad T460p!

  1. Might be a good idea to remove libpam-fprintd if you've alread installed it:
    $sudo apt remove libpam-fprintd
  2. Add the repo for libpam-fprintd which supports 138:0090
    $sudo add-apt-repository -u ppa:3v1n0/libfprint-vfs0090
  3. Install libpam-fprintd
    $sudo apt install libpam-fprintd
  4. Enroll your index finder using:
    $fprintd-enroll -f "right-index-finger" "$USER"
  5. Enroll all fingers:
    $for finger in {left,right}-{thumb,{index,middle,ring,little}-finger}; do fprintd-enroll -f "$finger" "$USER"; done

See here for more info: https://github.com/3v1n0/libfprint

7
  • IT WORKS! Tested it on a Lenovo T460p and it works flawlessly so far. Great work man! – Sean Bone Jun 21 '18 at 8:43
  • I've followed your instruction, but when trying to enroll finger, I got Enroll result: enroll-unknown-error. I'm trying to get it working on T460p with Ubuntu 18.04 installed. Do you have any ideas how to make it work? – mateuszb Aug 1 '18 at 21:50
  • tried this on my Lenovo p50 laptop. worked good until finger enrolls, output was: list_devices failed: No devices available – Zany_Zachary1 Apr 22 '20 at 15:13
  • I tried on t460s, ubuntu 18.04, output at step 4: list_devices failed: No devices available – le hien May 28 '20 at 4:35
  • Working for Lenovo P50 (ubuntu 20.04) – shantanu Jun 26 '20 at 19:06
5

I have an x1 carbon 4th gen which has the same fingerprint reader. I looked through the upstram libfprint source, and it doesn't look supported yet, so that's why it's not working. You will likely have to wait till someone creates a driver for it.

2

The effort to reverse engineering the protocol has begun and found some success here. Keep an eye on that project for a driver.

0

For Ubuntu 16.04 or greater:

Follow these steps to install the repo on a Lenovo B series (worked great with my Lenovo E450)

  1. $ sudo apt install libpam-fprintd
  2. $ fprint-enroll
  3. Swipe your finger on Finger scanner

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.