4

I'm running Ubuntu 14.04 without GUI and i'm having problems entering characters like backslash, slash, semicolon and so forth. The keys which would normally enter these characters print out all kinds of different characters instead.

How can i change this, so that i can actually type out the characters which are listed on the keys on my keyboard. I suppose this is some kind of problem with the layout of the keyboard, but i can't seem to figure out how to fix it. Furthermore, ctrl+x doesn't work either (which makes it hugely problematic when i want to edit files using sudo nano).

Any help would be greatly appreciated! Thanks.

3

You're probably using the wrong keyboard layout. You can change this by using the following command:

sudo dpkg-reconfigure keyboard-configuration
3
  • I have tried changing the keyboard layout numerous times. Some gives me partial funvtionality, so i can write backslash, slash and semicolon normally. Though these layouts still doesn't make me able to use the ctrl+c to exit files when using sudo nano. Apr 12 '16 at 13:18
  • Keep trying til you find the keyboard layout matching your hardware. It should work. Don't forget apply changes by running $ sudo setupcon
    – Ra_
    Apr 12 '16 at 14:22
  • Thank you! For some reason the raspberry pi distro defaults to a UK layout
    – Jason
    Jun 15 '20 at 0:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.