1

I tried to follow the steps listed here https://www.linux.com/blog/wine-1735-released-how-install-ubuntudebianlinux-mint

After adding the PPA and running apt-get update, when I try to install wine with:

sudo apt-get install -y wine1.7

I get this output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
wine1.7 : Depends: wine1.7-amd64 (= 1:1.7.44-0ubuntu1)
          Depends: wine1.7-i386 (= 1:1.7.44-0ubuntu1)
E: Unable to correct problems, you have held broken packages.

I also read this: Installing Wine on Ubuntu 15.10, but nothing seems to help.

Also, (I don't know if I should mention this in another question or if it is related to the current error I get) I had installed winetricks and it worked without any problem after installing "playonlinux" (I don't know if the problem started BECAUSE I installed playonlinux since I didn't use winetricks for days prior to trying to install playonlinux so the underlying problem may or may not have been created prior to this installation) I couldn't find winetricks on my apps list and right clicking on .exe files would pop winetrickes on "Open with" option...

Last but not least, in /usr/bin/ there is no winetricks executable, only a winetricks shell script.

1

From https://wiki.winehq.org/Ubuntu:

If your system is 64 bit, enable 32 bit architecture (if you haven't already):

sudo dpkg --add-architecture i386 

Add the repository:

sudo add-apt-repository ppa:wine/wine-builds

Update the package list:

sudo apt-get update

Then install (example for the development branch):

sudo apt-get install --install-recommends winehq-staging

If you prefer to use the devel (not Staging) branch, replace winehq-staging with winehq-devel in the line above.

If apt-get complains about missing dependencies, install them, then repeat the last two steps (update and install).

To install the latest version of Winetricks (recommended, the version in the repos is old), run:

wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks && sudo cp winetricks /usr/bin/ && sudo chmod +x /usr/bin/winetricks
  • well I dont know how to install the missing dependencies since from what i can gather (im a newbie :P ) the missing dependency is the package I want to intall in the frist place – papajo Apr 12 '16 at 0:53
  • this is the ouput when I try to install winehq-devel:The following packages have unmet dependencies: winehq-devel : Depends: wine-devel (= 1.9.7~ubuntu15.10.1) – papajo Apr 12 '16 at 0:53
  • Run sudo apt-get install --install-recommends winehq-devel wine-devel – QwertyChouskie Apr 12 '16 at 1:01
  • run sudo apt-get install --install-recommends winehq-devel wine-devel but it ouputs "The following packages have unmet dependencies: wine-devel : Depends: wine-devel-i386 (= 1.9.7~ubuntu15.10.1) " so I run sudo apt-get install --install-recommends winehq-devel wine-devel-i386 but it outputs "The following packages have unmet dependencies:wine-devel-i386:i386 : Depends: libasound2-plugins:i386 but it is not going to be installed" and when trying to run sudo apt-get install --install-recommends winehq-devel libsound2-plugins it outputs "E: Unable to locate package libsound2-plugins" – papajo Apr 12 '16 at 1:32
  • I suppose libsound2 belongs to a different repository but something tells me that even if installing it again an other problem will arise... 15.10 is such a fail it has so many dead ends and incompatibilities sometimes not even things that run on 15.04 can run on 15.10.... I should have installed the 14.04 version... poor me didnt get why there wasnt a 15.10 LTS version... now I know... – papajo Apr 12 '16 at 1:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.