0

I have spent all day solving how to get the Win7 guest to recognize my USB devices, and finally managed it, re-installed VirtualBox 5.0.16, re-installed Win7 into it from my CD, installed the Extension Packages and added myself to the Vbox users group..followed all the instructions to the letter, and was happily testing my favourite program in Virtual box, TMPGEnc, which wouldn't run because not enough memory, so I upped the base memory allocation to 1024 as required, and it worked. I was even able to encode a short video, just to prove to myself that I had finally managed to get VirtualBox working as guest on Ubuntu host. I only need it for a few programs. Then , I powered off the Virtual Box and when I went to start it again, there was no Win7, it had gone, and I was being asked to insert my disc to install a new machine all over again. What could have happened? is this normal? Is there any way out of this without yet again going through another Win7 install?

WJoe.

0

Make sure that you previously didn't run virtualbox as sudo, otherwise it has created new profile settings in /root account. Just run sudo virtualbox to check if you can see your machine. Another approach would be to look for the .vmdk or another possible guest disk files on the your system.

Edit: So previously you run VBox as sudo and the whole machine is probably in /root/VirtualBox VMs/<machine name> directory. You can copy/move machine folder to your /home/<youruser>/VirtualBox VMs/ and change machine folder owner to you with

sudo chown -R <user>:<user> <machinenamefolder>

being inside your VMs folder. After that probably you need to double click on win7machine.vbox file inside VM folder to show it inside VBox.

  • The sudo command found it, very good. Can you give more precise instructions on what to do once I find the .vmdk file please Michal. – WanderingJoe Apr 11 '16 at 14:01
  • I've edited answer – MichalTheDweller Apr 11 '16 at 14:28
  • bash: /root/VirtualBox: Permission denied – WanderingJoe Apr 11 '16 at 16:40
  • I entered this: /root/VirtualBox VMs/joevdisk – WanderingJoe Apr 11 '16 at 16:41
  • Do you still have problem? You need to run terminal, login as a sudo by typing sudo su - and then cd /root/VirtualBox VMs/ and perform rest of operations. – MichalTheDweller Apr 12 '16 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.