My mouse cursor is double the normal size. Its only the default pointer that is enlarged. Variations like resize, busy and so on are the correct size. The problem persists even when I change cursor theme.

If I move the cursor inside a Firefox window it changes to the correct size.

My resolution is 2560x1440, its a single screen setup. Nvidia-settings reports my DPI to be: 108x107. I've tired to force that DPI in the LightDM conf, since I figured it must have something to-do with the DPI calculation. I have tried to change the cursor size through dconf but the problem still remains.

I haven't seen this problem before, it arrived after the upgrade from Beta 2 to release version of Ubuntu 11.10.

Anybody got any idea what the problem might be, its pretty annoying with the huge cursor.

  • I am having the exact opposite problem as you do. Only the default "triangle" mouse have the correct size, the rest are huge. Did you find a solution yet? I think this problem is caused from the installer. I just installed ubuntu, and while I was borred, I set it to high contrast. This didn't change colors, but some input boxes as well as the pointer grew to the double size. – Tagger Nov 16 '11 at 18:50
  • I did find a temporary fix. – Rasmus Pedersen Dec 1 '11 at 22:06
  • I did find a temporary fix. First I made sure that the pointer size in dconf-editor was set to 24, (org>gnome>desktop>interface). Then I took the left_ptr image file from (usr/share/icons/dmz-white) and opened it with Gimp and removed the layers containing the images for 48px and 32px, leaving the 24px. Now since you say its all BUT the triangle that is affected I would remove the 48 and 32 layers from all other images. Remember to save the image again in the xmc format. Its a dirty hack, but it works. – Rasmus Pedersen Dec 1 '11 at 22:13
  • Wow that is a dirty trick, but I will definately check it out. Thanks – Tagger Dec 2 '11 at 14:01

You can set mouse cursor size for the user running lightdm. In my case it's root, so all I have to do:

echo "Xcursor.size: 24" >> /root/.Xdefaults

Hopefully it helps.

  • Not sure if it's obvious but I restarted the PC for the option to take effect. If anybody knows how to apply the option without a reboot... – sean.net Mar 28 '15 at 11:53

i had the same issue after changing from gdm to lightdm. my solution was to revert back to gdm and now my cursors are fine. to do this run

sudo dpkg-reconfigure gdm

and choose gdm as default.

protected by Community May 10 '12 at 12:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.