3

I apologize in advance for my bad english. I was trying to dual boot Windows 7 and Kubuntu 11.10, and i get this error 'Executing 'grub-install /dev/sda5' failed. This is a fatal error.'. every time when i try install GRUB on boot partition.Tried this on my desktop and laptop and always get this error. Hope anyone can help.Thanks!

3

Grub is installed on the hard drive, not on the partition. I'm assuming you want to create a seperate partition to mount on /boot, but grub-install should be used on a drive (/dev/sda in this particular case), not on a partition.

As long as you set everything right (mountpoints, that is), grub-install will automatically detect your settings and adjust itself accordingly.

  • In this lifeHacker article it says: "change the device for boot loader installation to the same partition on which you installed Linux (in the above case, /dev/sda4)." So they are wrong? – LoMaPh Jul 13 '16 at 22:24
1

ok do this: with a live cd

   sudo fdisk -l

to know where is installed you linux

   sudo mount /dev/sdaX/ mnt

X is where your kubuntu is installed

then

   sudo grub-install --root-directory=/mnt/ /dev/sda

then reboot normally and then

do this

   sudo update-grub
  • Thanks for your reply! I didnt aks this question well, this error happens during Kubuntu 11.10 install on a free space. – djuro Nov 5 '11 at 12:05
1

Here is how it worked for me:

Choose Try Ubuntu without installation

The system boots up with desktop on which there is Install Ubuntu copy the command of this icon (right click - properties - command)

Now open a terminal and do

sudo bash

run the copied command from here (I think the command was as below)

ubiquity %k ubuntu-desktop

And success.

I was installing 11.10 x64 on my desktop considering dual-boot where Windows XP x64 is already installed. I had kept provision of a boot partition in advance. The installation order does not matter.

/sda1 /boot 260M (primary)

/sda2 win-xp     (primary)
..
(2 more logical partitions)
..
/sda7 /    10g
/sda8 swap

While I was trying to install Ubuntu, I was getting fatal error while installing grub on /dev/sda1. I tried on /dev/sda without success.

Then I employed to run the installation from root shell. It worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.