0

since today I get the following message when inserting usbstick/sd card:

Aankoppelen bestandssysteem is mislukt
Error mounting /dev/sdb1 at /media/wouter/Kali Live: Command-line `mount -t "iso9660" -o "uhelper=udisks2,nodev,nosuid,uid=1001,gid=1001,iocharset=utf8,mode=0400,dmode=0500" "/dev/sdb1" "/media/wouter/Kali Live"' exited with non-zero exit status 32: mount: block device /dev/sdb1 is write-protected, mounting read-only mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

(udisks-error-quark, 0)

Here is the output of dmesg | tail

[ 995.732144] sd 12:0:0:0: Attached scsi generic sg2 type 0
[ 996.478994] sd 12:0:0:0: [sdb] 7643136 512-byte logical blocks: (3.91 GB/3.64 GiB)
[ 996.479683] sd 12:0:0:0: [sdb] Write Protect is off
[ 996.479692] sd 12:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 996.480485] sd 12:0:0:0: [sdb] No Caching mode page found
[ 996.480493] sd 12:0:0:0: [sdb] Assuming drive cache: write through
[ 996.522644] sdb: sdb1
[ 996.525979] sd 12:0:0:0: [sdb] Attached SCSI removable disk
[ 997.561414] ISOFS: Unable to identify CD-ROM format.
[ 999.938443] ISOFS: Unable to identify CD-ROM format.

It was working perfect until now. I do have ntfs-3g installed, so this could not be the problem.

  • Please be more specific - what kind of media to you try to mount? How is it connected? What do expect on the media? – cmks Apr 10 '16 at 17:56
  • The last time this external drive was connected to a Microsoft Windows system, did it work? Did you disconnect it politely, or just yank the cable? You should probably mount it on Windows the dismount it properly. – waltinator Apr 10 '16 at 18:53
0

Indeed, it was a matter of corrupt stick. I had a few memory sticks/sd cards after each other which gave me the same error which made me think that it was a settings fault, but it turned out to be the sticks themselves. Problem solved

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.