I'm experimenting with VPNs, so I wanted to install pptpd.

john@desktop:~$ sudo apt-get install pptpd
[sudo] password for john: 
The following extra packages will be installed:
The following NEW packages will be installed:
  bcrelay pptpd
0 upgraded, 2 newly installed, 0 to remove and 11 not upgraded.
Need to get 90.5 kB of archives.
After this operation, 442 kB of additional disk space will be used.
Do you want to continue [Y/n]? y

And everything runs fine until I get down to here:

WARNING: The following packages cannot be authenticated!
  bcrelay pptpd
Install these packages without verification [y/N]? n
E: Some packages could not be authenticated

No authentication? I'm no security expert, but I'm fairly sure that's a bad thing. So I check to see where the packages are coming from.

john@desktop:~$ apt-cache policy pptpd
  Installed: (none)
  Candidate: 1.3.4-3ubuntu1
  Version table:
     1.3.4-3ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
john@desktop:~$ apt-cache policy bcrelay
  Installed: (none)
  Candidate: 1.3.4-3ubuntu1
  Version table:
     1.3.4-3ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

They're coming from Ubuntu.com and not being properly authenticated? What's going on here?

6 Answers 6


apt-key utility

apt-key is used to manage the list of keys used by apt to verify packages. Packages which have been verified using these keys will be considered trusted. To update the local keyring with the keyring of Ubuntu archive keys and removes from the keyring the archive keys which are no longer valid.

$ sudo apt-key update
$ sudo apt-get update

try install something...

  • 15
    It worked, but apt-key said it didn't change anything. Any idea what my problem was?
    – John
    Nov 4, 2011 at 22:35
  • 5
    this can arise from a lot of errors on the package server side. sometimes running apt-get update will fix it.
    – ixtmixilix
    Sep 13, 2012 at 20:29
  • 4
    In my case, a Ctrl+C during a long aptitude work caused the problem. sudo apt-key update didn't change anything, but sudo apt-get update solved the problem.
    – musiphil
    Mar 21, 2014 at 5:35
  • 1
    It showing "Ubuntu Archive Automatic Signing Key <[email protected]> not changed " ..any other suggestion !
    – CoDe
    Jun 29, 2015 at 12:56
  • 2
    I wonder why apt-key update is not run automatically after encountering The following packages cannot be authenticated! problem... Jul 5, 2016 at 7:08
sudo apt-get update

Was enough to fix it for me.

  • 1
    Worked for me too on Ubuntu 14.04 with a freshly installed server (Ansible bug github.com/ansible/ansible-modules-core/issues/1497 in apt module caused the apt-get update not to be run.) I previously ran apt-key update to diagnose this but it didn't update any keys, so that wasn't the solution.
    – RichVel
    Oct 27, 2016 at 16:44

I had this issue on Ubuntu 12.10 (Quantal Quetzal). The same issue occurred if I tried to use the Synaptic Package Manager GUI.

It turned out that my system was still set to use a proxy server for a network I was no longer connected to and thus could no longer use. Once I disabled the proxy server, apt was able to authenticate the packages properly.

In order to disable the proxy on Ubuntu 12.10 (Quantal Quetzal), follow these steps:

  1. Press the Super button on your keyboard (A.K.A. the Windows Logo button)
  2. Type Network and press enter
  3. Select Network Proxy
  4. Change the method to None
  5. Click Apply System Wide
  6. apt should now be able to authenticate the packages

I had this problem, it turned out to be some fault with the Australian server - kangaroos loose in the top paddock, probably. I fixed it by changing the software source in Muon from Australian server to the main server


Beware corporate proxies!

I was getting WARNING: The following packages cannot be authenticated! for openjdk-7-jdk (amongst other packages), while sitting behind a proxy. Even configuring `/etc/apt/apt.conf' and Settings->NetworkSettings with Proxy config didn't allow the packages to be authenticated or installed.

Tried (while behind proxy): $ sudo apt-key update $ sudo apt-get update

Keys weren't updated, apt-get update updated some stuff, no warnings or errors. But I still couldn't could install openjdk-7-jdk.


  1. Connect directly to net (ie avoid the corporate proxy)
  2. Switch off proxy config in Settings and /etc/apt/apt.conf
  3. sudo apt-key update
  4. sudo apt-get update
  5. sudo apt-get install openjdk-7-jdk

Packages are authenticated, downloaded and installed.

  • 4
    But why? Why is going through a corporate proxy prevents proper authentication of package?
    – Mikhail T.
    Aug 23, 2017 at 21:22

ntc2 is essentially correct (for my case anyway), but allow me to elaborate on the solution.

For whatever reason I was stuck on 15.04 even though it was set up to auto upgrade. No matter how many times I updated/upgraded no new release was being shown, and I kept getting the authentication error when installing packages.

However I finally figured out how to force the upgrade via the official Ubuntu 15.10 (Wily Werewolf) Release Notes. Turns out to be fairly simple, and in my case all I really needed was the last step.

Upgrading from Ubuntu 15.04:

  • Install the update-manager-core package if it is not already installed.
  • Make sure the /etc/update-manager/release-upgrades is set to normal.
  • Launch the upgrade tool with the command sudo do-release-upgrade.

Now that I've upgraded the authentication error is resolved and I can install packages without issue.

Upgrade issue - E: Method gave invalid 103 Redirect message

This might or might not be related to the upgrade issues so I'll leave this here in case anyone else also encounters this. If during the upgrade you encounter the following error:

E: Method gave invalid 103 Redirect message

You might have to clean out the partial files with the below and retry the upgrade:

sudo rm /var/lib/apt/lists/partial/*

(Source: https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1479045)

This was the final piece to make the upgrade go through for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .