0

I have a laptop with hybrid graphics. I'm using that xserver-xorg-video-ati driver. Ubuntu seems to be using the Intel GPU for rendering graphics. How do I switch to AMD graphics without installing fglrx drivers? I tried that vgaswitcheroo thing but I wasn't able to switch to AMD.

kyuunex@Ayumi-Linux:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7550M/7570M/7650M] (rev ff)
  • Can you not select the default graphics device to use in your system's BIOS configuration? – dobey Apr 9 '16 at 14:00
  • This is a laptop. I can't disable Intel graphics. I can only disable AMD. – Kyuunex Apr 9 '16 at 14:09
  • I didn't say to disable. I said select as default. Yes, it was apparent that you are most likely on a laptop. – dobey Apr 9 '16 at 14:15
  • There is no option to select a default GPU in BIOS. – Kyuunex Apr 9 '16 at 14:18
0

You can blacklist the driver, by creating an /etc/modprobe.d/blacklist-i915.conf with the contents:

blacklist i915

You can also uninstall some packages for Intel video:

sudo apt-get remove --purge xserver-xorg-video-intel intel-gpu-tools libdrm-intel1

Then upon rebooting, with the AMD GPU enabled in BIOS, Ubuntu should only see the AMD GPU as usable.

  • pastebin.com/ddfWeNzA – Kyuunex Apr 9 '16 at 15:33
  • That seems unrelated. Does apt-get -f install do anything? – dobey Apr 9 '16 at 15:35
  • Or just leave libdrm-intel1 installed instead, perhaps. – dobey Apr 9 '16 at 15:37
  • apt-get -f install doesn't help. I left libdrm-intel1 installed, rebooted, and it's still using intel GPU. Looks like I have to blacklist. – Kyuunex Apr 9 '16 at 15:45
  • Didn't work. Only difference is that it booted with a glitched out "Ubuntu" screen and then started unity just fine on Intel. – Kyuunex Apr 9 '16 at 15:51

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.