2

I've run into an issue where my USB 3.0 ports seem to be intermittently failing. I have two ordinary USB 3.0 ports on my computer and I have my wireless keyboard/mouse combo plugged into one and a WIFI adapter plugged into the other. Every so often, the keyboard will become unresponsive for a few moments and the internet will hang and become unresponsive until the adapter is restarted. In addition, I have 8 high power USB 3.0 and two USB 2.0 ports which do not function at all (stuff plugged into them is detected very infrequently). So possibly I am using the wrong drivers?

The output of lsusb is (when it works, it sometimes just hangs and requires a manual termination):

Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 011 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 010 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 009 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter
Bus 001 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I've already tried editing grub by modifying it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"
GRUB_CMDLINE_LINUX="acpi=force irqpoll"

but neither of those changes seem to have made any difference. The 3.0 ports still fail occasionally and none of the other ports work at all.

Any help you guys could offer would be hugely appreciated.

  • I should also probably mention that the USB ports work fine in windows. – Graham Reid Apr 8 '16 at 17:23
2

By itself, modifing the grub had no effect on the performance of the USB ports.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"
GRUB_CMDLINE_LINUX="acpi=force irqpoll"

However, I finally did what I should have done within 30 seconds of realizing that there was a problem with my USB ports and looked up my motherboard (a gigabyte ga-990fxa-ud3). This thread describes a simple solution to the problem which involves going into the BIOS and setting IOMMU to "Enabled".

Together with the grub options, this took care of the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.