10

I don't know what I've done, but when I press and hold the key "Backspace" it just deletes only 1 character and stops. This is everywhere: in the console, Chrome, Text editors.

I'm running Ubuntu 14.04 LTS.

1
  • Is it only for the Backspace button ? Have you tested your keyboard in other OS/PC ? try to clean it up if the prob is persists
    – storm
    Apr 8, 2016 at 8:33

2 Answers 2

13

Go to unity-control-center keyboard and make sure keyboard repeat is enabled

or use gsettings to change value:

gsettings set org.gnome.desktop.peripherals.keyboard repeat true
4
  • You are a lifesaver, thanks! Had the same issue on Ubuntu Budgie 17.10 Apr 21, 2018 at 13:43
  • Glad to hear it still works
    – EdiD
    Apr 21, 2018 at 14:50
  • On 16.04, my was still enabled when I opened unity-control-center. Simply unchecking and rechecking solved the issue.
    – RoraΖ
    Apr 26, 2018 at 13:10
  • This didn't work on Ubuntu 22.04. This worked for me, "xset r on". Run in terminal without quotes. Credits to @varshneydevansh as he posted below the answer.
    – 74H1R
    Apr 9 at 22:41
7

The xset utility can be used to enable keyboard repeat. It works on the X.org level, so should override whatever the distribution is doing wrong.

To enable keyboard repeat, execute:

xset r on

For details, see man xset.

It worked for me on Ubuntu 18.04.

4
  • 2
    just needed this command on Ubuntu 20.04. Dec 13, 2020 at 18:44
  • 1
    "xset r on" also works with kali linux thanks to @varshneydevansh
    – Sonu Kr
    Jul 2, 2022 at 10:53
  • 1
    Ubuntu 22.04 here. It works. Thanks.
    – 74H1R
    Apr 9 at 22:38
  • Glad. It helped you :) Apr 21 at 6:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .