4

I recently installed Ubuntu 15.10 on my old computer. I'm now trying to create a windows usb stick to install on a new computer I'm building. When I add the repository

    sudo add-apt-repository ppa:colingille/freshlight

and I try to update, I get the following errors:

    W: Failed to fetch http://ppa.launchpad.net/colingille/freshlight/ubuntu/dists/wily/main/binary-amd64/Packages  404  Not Found                         

    W: Failed to fetch http://ppa.launchpad.net/colingille/freshlight/ubuntu/dists/wily/main/binary-i386/Packages  404  Not Found

    E: Some index files failed to download. They have been ignored, or old ones used instead.

Then when I try:

   sudo apt-get install winusb

I get:

   E: Unable to locate package winusb

Can anyone help me find a solution?

2
  • 1
    The 404 "error" seems to suggest there are no package candidates on that repository for ubuntu willy. – xangua Apr 8 '16 at 4:18
  • I think you can follow the guide on WinUSB's GitHubclick here. That is really helpful! – Masimov Jan 10 '17 at 12:35
5

To install in Ubuntu (16.04, 15.10, 15.04 and 14.04) or Linux Mint (17.x or 18) and derivatives. To add the PPA and install WinUSB, use the following commands:

sudo add-apt-repository ppa:nilarimogard/webupd8

sudo apt update

apt install winusb

3
  • Silly question but How to run it? winusb command not found. – LRDPRDX Jul 23 '18 at 7:14
  • @LRDPRDX, have You installed it? :) Look for it in Programs Menu. – Aleksey Kontsevich Jul 23 '18 at 12:46
  • Of course I've installed it (using apt-get manager). I am using i3 wm. It's seems that command to run is woeusb. – LRDPRDX Jul 23 '18 at 23:10
3

The Winusb package is not available from this PPA for Wily but there is a technique that worked well on my system to install it using the Saucy package. I have tested this under Trusty but it should also work under Wily:

Firstly download either 64bit or 32bit package from the PPA:

64bit:

wget https://launchpad.net/~colingille/+archive/freshlight/+files/winusb_1.0.11+saucy1_amd64.deb

32bit:

wget https://launchpad.net/~colingille/+archive/freshlight/+files/winusb_1.0.11+saucy1_i386.deb

Then install the file:

sudo dpkg -i winusb_1.0.11+saucy1*

You will see errors such as the following:

andrew@corinth:~$ sudo dpkg -i winusb_1.0.11+saucy1*
(Reading database ... 197467 files and directories currently installed.)
Preparing to unpack winusb_1.0.11+saucy1_amd64.deb ...
Unpacking winusb (1.0.11+saucy1) over (1.0.11+saucy1) ...
dpkg: dependency problems prevent configuration of winusb:
 winusb depends on libwxbase2.8-0 (>= 2.8.12.1); however:
  Package libwxbase2.8-0 is not installed.
 winusb depends on libwxgtk2.8-0 (>= 2.8.12.1); however:
  Package libwxgtk2.8-0 is not installed.
 winusb depends on gksu; however:
  Package gksu is not installed.

dpkg: error processing package winusb (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Errors were encountered while processing:
 winusb
andrew@corinth:~$ 

Fix the errors:

sudo apt-get -f install

It is a very clumsy method (and certainly will not work for all deb packages!) but has certainly worked on my Trusty system and should also work on Wily:

enter image description here

References:

1
2

There is a fork of winusb which works great in my Ubuntu Mate 18.04

It is WoeUSB

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install woeusb

You will find the launcher icon in the menu (or search in the menu).

1

WinUSB won't work properly on Ubuntu 18.04.

Use woeUSB instead:

sudo apt-get install woeusb

Just restart the system after installation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.