2

In my GRUB configuration, I have the following setting:

GRUB_TIMEOUT=3

In general, it works fine. However, I'm using overlayroot, which creates a protected file system (specifically, it uses OverlayFS to create a union filesystem). When I reboot, the GRUB timeout reverts to 30 seconds. It's important to note that the necessary config changes were made with the file system in read/write mode, so whether the file system is in read-only or read/write mode, the config file is the same (and reflects the correct timeout).

Can anyone shed some light on what might be going on? My best guess is that GRUB isn't detecting that the previous boot was successful, so it is overriding the timeout and setting it back to 30.

Thanks!

1
  • Are you hibernating? If so, are you also using systemd as your init system? Aug 11, 2016 at 16:52

1 Answer 1

6

Here's one answer. I'm not sure what mechanism causes a recordfail situation, but adding this line to the grub config seems to do the trick:

GRUB_RECORDFAIL_TIMEOUT=$GRUB_TIMEOUT

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.