1

Yesterday an upgrade to OTA-10 was available on my Meizu MX4 Ubuntu Edition. I downloaded the upgrade, and clicked the "install" button. Confirmed that the device was allowed to restart, and saw the device restart and an ubuntu logo came up. After about 30-50 seconds the Ubuntu logo was replaced by a picture of a small sign/icon of a computer-chip with a red cross behind it. Apparently something went wrong - but no form of error message was shown. The device was unresponsive - only thing to do was turn it off. When turned on again, it booted like normal - but the device is back to OTA-9.1. That is, I see a few subtle changes in graphics, and under phone information it clearly states OTA-9.1. What went wrong? What to do about it? How do I get it to fully upgrade to OTA-10?

PS: The update/upgrade to OTA-10 is still available, and I have tried to install it a couple of times - to no avail. Same thing happens again ...

PPS: I have nothing special installed or developermode or read/write turned on, or played with apt-get etc. Plain factory reset phone, that has been used as a normal smart-phone and nothing else for a couple of months.

0

I have excatly the same problem as you. I have filled bug for this behavior here: https://bugs.launchpad.net/canonical-devices-system-image/+bug/1568889

  • I should add that I cannot recommend doing a factory reset. I thought perhaps it would help upgrade to OTA-10 - but that completely bricked my device. Meizu bootscreen loops when doing a normal boot. Recovery mode leads to an Ubuntu logo, but device is unresponsive. Fastboot mode is available, but trying to ubuntu-device-flash a new recovery image has had no effect whatsoever. – Lars Kristian Wichmann Hansen Apr 12 '16 at 17:58
0

I had the exact same problem on a Nexus 7.

I just tried again, this time using a writable image, and issued this via ADB:

ubuntu-device-flash touch --channel=ubuntu-touch/stable/ubuntu

It worked!

I'm not sure if the writable image has any effect. You might want to try this with your current image, after making sure you're using the appropriate channel for your device.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.