2

This afternoon I installed TLP on my laptop running Ubuntu 14.04.

After the restart my WiFi suddenly stopped working _ message: "Disconnected - you are now offline" - I have a button on my keyboard that turns wifi on/off - now it just stays red and doesn't change (to blue) at all when pressed. - In my network indicator now there no option even to turn wifi on/off and its the same in system settings

  • RFKILL LIST ALL gives me:
hp-bluetooth: Bluetooth
        Soft blocked: yes
        Hard blocked: no

And no wireless mentioned at all.

  • Attempted fixes: (that did not work)
    1. Change the following in TLP's configuration:
WIFI_PWR_ON_BAT=1
WIFI_PWR_ON_AC=1
  1. sudo service network-manager restart

  2. I then uninstalled TLP (and purged) - still nothing

  3. I then uninstalled other things I installed earlier in the day: Weather and calendar indicators, and preload.

    • NOTE: i noted in my software center there was 3 changes in the history that i did not recognise: Removal of : Python3 tz, Python dateutil and python3-dateutil (I do not know what these are signifying)

I do not know what wireless card I have or how to find that out.

Kindly assist me please

EDIT:

  • Wireless card: EDIT: found this: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
  • Running the following didnt change anything
    sudo add-apt-repository ppa:hanipouspilot/rtlwifi
    sudo apt-get update
    sudo apt-get install rtlwifi-new-dkms-linux-firmware
    sudo apt-get update && sudo apt-get upgrade

Edit: Seems like my wireless driver has been uninstalled somehow? am I interpreting this correctly?

sudo lshw -c network

Output

description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller

Nothing saying Wireless interface???

0

I had an issue with my WiFi card when I installed Ubuntu on my older laptop. The same issue with the WiFi being disabled occurred. I found that I had to install necessary WiFi drivers and I found those.

Works with my WiFi card listed below:

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rflwifi-new-dkms-linux-firmware
sudo apt-get update && sudo apt-get upgrade

Also, as far as looking for your wi-fi card you can find it by typing:

ifconfig

your wireless card should be under wlan0 if not try:

sudo lshw -short

(reference)

This will display all current hardware including the wireless card which will be under the Class - Network category and have a description similar to something like this:

AR9285 Wireless Network Adapter (PCI-Express)

Also, it seems like TLP will heavily configure your settings even overriding some of yours in order to save battery life or so I have read. You can try editing the configuration file by typing:

gksudo gedit /etc/default/tlp

and search for these settings: WOL_DISABLE=Y and WIFI_PWR_ON_AC=1 WIFI_PWR_ON_BAT=5

(reference)

  • heres the reference: linrunner.de/en/tlp/docs/tlp-configuration.html – subutai Apr 7 '16 at 16:30
  • You are welcome. To be more specific, I would try changing the configuration settings in the TLP file first. Switch the WIFI_PWR_ON_BAT=5 to WIFI_PWR_ON_BAT=1 . It sets the wi-fi power saving mode which 5 means enabled and 1 means disabled. Obviously you want the power saving for your wifi card disabled. – subutai Apr 7 '16 at 16:35
  • Hi - the above fix didn't help. Also - I tried changing WIFI_PWR_ON_BAT=5 to 1 as noted in my post #1. Thanks for trying – Edward Miles Apr 7 '16 at 19:26
0

I faced the same problem,

I fixed my problem by

Uninstalling TLP and Installing Wireless Drivers

Command: (to remove tlp) (sorry I have OCD)

sudo apt-get purge tlp
sudo apt-get autoremove
sudo apt-get clean all
sudo apt-get autoclean

Command: (to install 802.11 drivers) (I am on Kali rolling and using Wicd network manager)

sudo apt-get install firmware-brcm80211 firmware-b43-installer firmware-b43legacy-installer broadcom-sta-dkms

if you don't know the repository of Kali: ( Paste this in /etc/apt/souces.list and save )

deb http://repo.kali.org/kali kali-rolling main contrib non-free

I also noticed, while installing tlp, the package arping was replaced by iputils-arping. Hence,

sudo apt-get install arping

Restart Required

Thats it!

(if this works for you, please upvote so I can get right to answer, comment, upvote, etc)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.