4

How to setup VPN on Ubuntu Touch? I have paid account with NordVPN. I have followed their tutorials for setting up in different OS's and assembled from there various setting as per screenshot:

enter image description here

It does not work (connection failed) Firstly, I'm missing a place to add my NordVPN user name and I'm not sure what file to upload as Private Key. The rest of the files are downloaded from NordVPN site: https://nordvpn.com/tutorials/ Any help or link to this new great feature will be appreciated. Thanks

3

There is a click-package that provides more configuration-options, including ca-certificate only with username and password. But you still cannot import the ovpn-file. You have to set the options manually in the app.

Get the latest (0.3.1) click-package here, you can download it directly to the phone: http://people.canonical.com/~pete/vpn-editor/

Then install it with this command from the phones terminal app:

pkcon install-local --allow-untrusted ~/Downloads/com.ubuntu.developer.pete-woods.vpn-editor_0.3.1_all.click

VPN-Editor should appear in the App-Scope. There you have a lot more options... Good luck.

| improve this answer | |
  • this command gives me Fatal error: could not resolve: --allow-untrusted Does the phone need to be in developer mode? – Pavel Perina Apr 11 '16 at 1:31
  • uh, yes thats quite possible, mine was in developer mode. – Luksus Apr 11 '16 at 12:58
  • I have switched the phone into developer mode, but still the same error message appears! Could somebody help me to identify the problem please? – Pavel Perina May 11 '16 at 11:46
  • You do not need to be in developer mode to use pkcon. Make sure that the complete command is correctly written with the "install-local" option. – vmalep Jun 5 '16 at 5:00
2

Thank you Luksus. using this vpn-editor everything could be specified. For cyberghost-VPN I mainly took the parameter settings from the file openvpn.ovpn (e.g. Remote server address and portnumber) and I was now also able to specify my username and the password. enter image description here

These settings work for me.

(update march 2017: with OTA 15.04 this does not work any longer in my case, there seems to be a bug. VPN connection failed because there were no valid secrets)

| improve this answer | |
1

I found that Nord do not use a user certificate, so the 'Type' setting for the main openvpn page should be set to 'Password'. After playing around with the other settings, I finally found the correct setup as shown in this set of screeenshots using the uk30 nordVPN server as an example. Note that the Proxies page was left blank as default:

enter image description here

Thanks Luksus and pewe20 for your posts which got me started on the right path

| improve this answer | |
  • Pavel Perina, regarding your additional problem with the Fatal error when attempting to install the VPN-editor, even though you were in developer mode, I cannot think of anything to suggest other than to run any suggested updates on your device. In case it helps, it all worked on my BQ Aquaris E4.5, running OTA10. – micalith May 17 '16 at 20:00
  • note that this setup still works with OTA-14 – micalith Dec 10 '16 at 17:01
  • Pavel Perina, it seems that some Nordvpn servers work and others don't. I can connect to de111.nordvpn.com, but nl38.nordvpn.com gives me the similar error, "The VPN connection to "au1.nordvpn.com" failed because of invalid VPN secrets" – micalith Dec 12 '16 at 12:40
0

The click package works fine for me (with pfSense) on BQ Aquaris-M10. I was also missing a option to put in a username and password.

Just make sure to provide a list with DNS servers to the tablet/phone as this cannot be edited on the mobile device.

| improve this answer | |
0

As I was having the same VPN connection error message as in OP's first comment regarding OTA11 to the original question, I really thought that it was a Nord issue. After some time with Nord support, it turns out that in the server VPN settings for two different servers, I had entered a username incorrectly in one and the password incorrectly in the other.

Definitely go back and re-enter your username and password to be sure.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.