2

If I write a line containgin ž in konsole or kwrite, the line height gets messed up. Is the default font broken, or is it the apps? Didn't know where to report the bug, so "ask ubuntu" sounded as a good start.

How to reproduce:

  1. Open kwrite, kate or console
  2. Write __
  3. Then add a ž on the same line so you now have __ž

Expected behavior:

  • The other chars should stay the same when I add a ž

Current behavior:

  • The __ is no longer visible, guess all text get their lowest pixels removed, the _ char only have lower pixels, so easier to spot there.

In konsole, the cursor position make some differences, think it draws the text in 3 parts: before, on, and after cursor, so only the parts that include the ž char gets the error, if you wirte __ž__ and put the cursor on the ž char, you can see the __, but if you write __ž__ž__ you can see the 3 different parts acting.

Screenshoots as requested, first from Konsole:

4 screenshoots from konsole

In the screenshoo i first wrote: __ž__ž__ and then just moving the curser between the 4 screenshoots.

Screenshoot from kwrite: enter image description here

Submitted bug-report:
https://bugs.launchpad.net/ubuntu/+source/oxygen-fonts/+bug/1594848

  • Could you add screen shots how it should be and how it is? – user.dz Jun 18 '16 at 11:37
  • 1
    Can at least add screenshoots on how it is now, a bit harder to screenshoot how it supose to be, as I have problem getting there :-) – Puggan Se Jun 20 '16 at 13:30
  • OK, it is clear now. Could you tell me which Kubuntu is this ? – user.dz Jun 20 '16 at 13:47
2

I'm able to reproduce same issue on Kubuntu 15.10 (VBox). It is a font problem. It happen with "Oxygen Mono", it doesn't with "Ubuntu Mono" & "Deja Vu Mono".

  1. Find the corresponding font file

    $ fc-match "Oxygen Mono"
    OxygenMono-Regular.ttf: "Oxygen Mono" "Regular"
    
  2. Find the source package and the full path

    $ dpkg -S OxygenMono-Regular.ttf
    fonts-oxygen: /usr/share/fonts/truetype/oxygen/OxygenMono-Regular.ttf
    
  3. Collect info

    ubuntu-bug /usr/share/fonts/truetype/oxygen/OxygenMono-Regular.ttf
    

    Then send (It will open a link in the browser)

  4. Complete Lauchpad bug report and submit

If things get slow, You may submit another report to upstream project KDE. Just update both reports to include the links to each others.

Here a command to show package info including the upstream link...

$ apt-cache show fonts-oxygen
Package: fonts-oxygen
...
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
...
Source: oxygen-fonts
Version: 4:5.4.3-0ubuntu1
...
Homepage: https://projects.kde.org/projects/kde/workspace/oxygen-fonts
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 3y
...
  • 1
    Thanks for your time, have reported it at bugs.launchpad.net/ubuntu/+source/oxygen-fonts/+bug/1594848 (should i mark this as solved in askubuntu now, or after it is fixed?) – Puggan Se Jun 21 '16 at 14:55
  • @PugganSe, mark it accepted here, as It does answer your question "Is the default font broken, or is it the apps? Didn't know where to report the bug" , and because Ask Ubuntu is not for tracking bugs. Just don 't forget to add an update note down the question mentioning the submitted but report. I will help others facing same issue. – user.dz Jun 21 '16 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.