14

I have VirtualBox running on several server installations, always without any GUI, administering using the vboxmanage commands.

I used to install from the Oracle PPA, but since the end of the two different versions of vbox, I've been installing from the Ubuntu repos. I've found the package for installing the guest additions iso, but never been aware of the extension packs being there.

I'm asking as the virtualbox version for 14.04 moved from 4.3.10 to 4.3.34 a little while back, so added a step for me running apt-get dist-upgrade.

I know how to get hold of these from Oracle and install them manually, but is there another method, without using GUI? Are the extension packs anywhere in the Ubuntu repos?

14

Because the Virtual Box extension pack is closed source proprietary software we will not be able to provide debian packages or binaries from the Ubuntu repositories.

To ease installing of extension packs to Virtual Box versions provided by the repositories we maintain a download helper script in the multiverse repository from Ubuntu >= 15.10 which will download the extension pack from Oracle (virtualbox-ext-pack).

Do not install this for Virtual Box versions you had downloaded and installed from other sources.

  • 2
    virtualbox-ext-pack downloads whatever Oracle currently has, trying to install, but is essentially untested on your system. Installing virtualbox-ext-pack via the "software updater" broke my system (Ubuntu 17.04), hanging waiting on a "license agreement" -- with no way to "agree". This is a bug in the post-install script, and there's no way to recover, besides removing it. It'd be safer to avoid this package and rather install the extension pack on the command-line via VBoxManager or the GUI (file>preferences>extensions>add, select pre-downloaded file, agree to license). – michael May 26 '17 at 17:30
  • @michael_n: too true... it should try at least to download and agree to the extension pack matching the repository version of Virtual Box. I always download manually too. – Takkat May 26 '17 at 18:06
  • 1
    @LuísdeSousa the virtualbox-ext-pack download helper still is provided for 16.04, 17.04, and 17.10. After accepting the license it will download and install the extension pack for the repo version of virtualbox to /usr/share/virtualbox-ext-pack from http://download.virtualbox.org/virtualbox/. What does "not function" in your case? – Takkat Jul 26 '17 at 21:52
  • 1
    I tried to install this package on Ubuntu 16.04, Lubuntu 16.04 and Ubuntu 17.04. It always fails to install the Oracle extpack after downloading. A number of systems errors follow. Like @michael reported above, on Lubuntu 16.04 the system became unstable. Avoid the virtualbox-ext-packpackage at all costs. – Luís de Sousa Jul 27 '17 at 6:23
  • 1
    @LuísdeSousa: the question asked for a way to install it from Ubuntu repositories - this is the only way I know of. If that package does not work as expected in your case you should report it as a bug to the package maintainers. If your "system became unstable" it is likely you accidentally tried to install it for a virtualbox version other than that from the official repositories. Note that virtualbox-ext-pack is meant only for the repository.version of virtualbox and it will install this version as a dependency. – Takkat Jul 27 '17 at 6:36
16

This assumes virtualbox is already installed.

I looked at the source of the virtualbox-ext-pack package in Ubuntu and I found some gems. I did the following which is a variation on what that package does in a script I am using:

VBOXVERSION=`VBoxManage --version | sed -r 's/([0-9])\.([0-9])\.([0-9]{1,2}).*/\1.\2.\3/'`
wget -q -N "http://download.virtualbox.org/virtualbox/$VBOXVERSION/Oracle_VM_VirtualBox_Extension_Pack-$VBOXVERSION.vbox-extpack"
VBoxManage extpack install --replace Oracle*.vbox-extpack

This was on debian jessie, but I am quite confident it would work the same on most any flavor of linux, possibly unix too.

  • Thanks Arronical. By the way, I personally don't see the currently accepted answer (by Takkat) as a very viable solution for reasons of backwards compatibility and the fact that Ubuntu 15.10 is not an LTS. 15.04 support is already discontinued and 15.10 will only see support until July 2016. Once the next LTS (16.04 I would assume) is out then Takkat's answer would be the best for sure, but there is no release date even announced for that right now. – nicholas.alipaz Apr 20 '16 at 15:50
  • What he means is that from 15.10 onwards (>=) will have the virtualbox-ext-pack package in the repositories. I suppose he answers the question about whether the ext pack is in the repos, and you give a solution that should work on 14.04, which is my version. My fault for asking 2 questions in one! Also I believe that the release date for 16.04 Xenial Xerus is tomorrow wiki.ubuntu.com/XenialXerus/ReleaseSchedule . As I was asking about 14.04, I'll give your commands a go when I get a chance, and accept your answer if they work, they look sensible to me. – Arronical Apr 20 '16 at 15:57
  • Arronical, oddly enough I hadn't seen the impending release of 16.04. But yes I did understand that his answer specifies that from 15.10 onward there will be a solution using virtualbox-ext-pack package. I was trying to note that albeit that does answer the question as to how to install from the repositories, it doesn't provide a solution for anyone in older releases. And I do agree your question was a little loaded since you asked two things, 1. if it can be installed from repo and 2. how to do it with some other method that is non-gui. It may even be prudent to reword the actual question. – nicholas.alipaz Apr 20 '16 at 18:23
  • By the way, the only part of those commands I actually wrote was the first line since I needed to get the virtualbox version number. The rest was ascertained from the virtualbox-ext-pack with an alteration of adding the $VBOXVERSION into the mix. – nicholas.alipaz Apr 20 '16 at 18:29
  • works nicely with 16.04. Had to add sudo in the last command. – kmonsoor May 26 '17 at 10:59
9

On Ubuntu 17.04+:

sudo apt install virtualbox-ext-pack

PS: I know this question was made a long time ago when this was not an option, but I'm writing this answer to help people that came here through Google in 2018+.

  • 2
    I appreciate this post. – j0h May 10 '18 at 14:44
7

apt-cache search virtualbox gives me an virtualbox-ext-pack which is the pack youre looking for.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.