0

My Problem

I have some problems starting up my Lenovo T540p in the docking station. If I start outside the docking station Linux is started and everything is perfect. I can put the notebook into the docking station and use two more displays.

If the notebook is in the docking station, I can make a reboot in the docking station and the computer restarts normal. But if I turn off and on the notebook, while it still in the docking station, it stops running with a blinky cursor in normal textmode 80x20 (I mean the textmode known from MS-Dos, with no graphics). Holding down the Shift button while starting up shows me "GRUB Loading."(also in textmode 80x20). There is nothing more, no error number nothing. I start my OS via USB, but as far as I can remember the problem also exist running normal SATA-HDD.

My docking station

I use the normal docking station for the notebook.(Not the one using the USB-Interface)

https://www.cyberport.de/?DEEP=1D02-6AY&APID=117&gclid=CJjw6tmL_MsCFUWNGwodyLYKSw

I tried different distributions: Mint, Fedora, Mint 17.3, Debian 8.4 with KDE, Ubuntu 15.10. Its always the same.

I read (google,manjaro.org)

[SOLVED] Grub not loading thinkpad_acpi in docking station

and tried to use thinkpad_acpi in an extra file (like it was described there)!

I read

http://www.thinkwiki.org/wiki/Thinkpad-acpi

and found out that thinkpad_acpi is not longer in use. In stead of using thinkpad_acpi, I should use ACPI bay! ? :-(

Also playing with acpi should not be harmless at all because important devices like fan control would be deactivated. (If this is true I do not know)

I read (google,it is in askubuntu)

How do I disable ACPI when booting?

and used acpi in GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

I tried some modification of GRUB_CMDLINE_LINUX_DEFAULT="..."

-nomodeset

-xforcevesa

-"" <-nothing etc.

I tried different settings for the display in the bios. No Display, Display in Dockingstation etc.

Software Version

sudo X -version X.Org X Server 1.17.2 Release Date: 2015-06-16 X Protocol Version 11, Revision 0 Build Operating System: Linux 3.13.0-68-generic x86_64 Ubuntu Current Operating System: Linux ***** 4.2.0-16-generic #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015 x86_64 Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.2.0-16-generic root=UUID=7fb2e262-0d61-4640-954a-7c9b79acf84c ro quiet splash --- vt.handoff=7 Build Date: 12 November 2015 05:33:29PM xorg-server 2:1.17.2-1ubuntu9.1 (For technical support please see http://www.ubuntu.com/support) Current version of pixman: 0.32.6 Before reporting problems, check http://wiki.x.org to make sure that you have the latest version.

uname -a Linux *** 4.2.0-16-generic #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

GRUB Bootloader

cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

lspci

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 8 Series/C220 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-LM (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d4)
00:1c.1 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #2 (rev d4)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d4)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM87 Express LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 04)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01)
04:00.0 Network controller: Intel Corporation Wireless 7260 (rev 83)

I learned a lot but I can not find a solution for the problem. I do not want to flash the firmware as it described on some webpages. Because my displays do not flicker and they are working.

Does anyone have the problem ?

0

I found a way to handle the problem. The first time I used the PC, I thought the problem appears while using a second Monitor. Ubuntu always told me having trouble with X. When I released the Monitor everything worked fine. In the newer releases of Ubuntu this monitor-error doesn't occur anymore. I never had the idea to release something else at back of the docking station.

Today I read on a webside, somebody solved the problem by pulling off every USB Device. I did so too. I released keyboard and mouse and (behold) it started up. I tried to use only one device and also the pc starts up. Only the combination of both devices will show the blinky cursor and makes the pc halt.

For both devices (mouse and keyboard) I use a USB-Hub which works fine for me. Its not the best solution using a HUB and still haveing USB-Ports left at the ds. Also I do not really know where the error comes from.

I am interested whats happening there!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.