0

Email-server setup is not working on Ubuntu 16,postfix,dovecot.
below are the config/facts

  1. Registered a domain say atul.com
  2. ISP is comcast who blocks port 25
  3. Created A record @ -- 1.2.3.4
  4. No CNAME except www
  5. MX Record mail -- @
  6. all ports are open like 110, 143,993,995,465,587
  7. I am able to send/receive mail at local users with xyz@atul.com, root@atul.com, atul@atul.com
  8. I am able to telnet mail.atul.com 465 and @587
  9. I do not have any mail subscription/account @godaddy.com
  10. I allowed all necessary ports on my router

My Doubts/Questions:

  • Why I am not able to receive email from outside domain? (even when I am able to telnet on mail.atul.com 587)?
  • Why I am not able to send mail to outside from my domain? while I tried setting my relayhost on below settings
relayhost = blank
relayhost = *
relayhost = email.secureserver.net

My Question on relayhost is :

  • Can't I setup my independent mail server? without any intervene by comcast or godaddy? Because I don't want to use their mx records or smtp server.
  • What all I need to do if I don't want to use their MX Records (smtp server)
  • Please Guide me to place correct values for below Fields

     
    A Record, 
    CNAME, 
    MX Record , 
    myhostname, 
    mydestination,
    relayhost
    

Below are the Different configuration I am using...

main.cf

myhostname = mail.atul.com

mydestination = atul.com, mail.atul.com localhost.localdomain, localhost

relayhost = [email.secureserver.net]

master.cf

# ==========================================================================

# service type private unpriv chroot wakeup maxproc command + args

# (yes) (yes) (no) (never) (100)

# ==========================================================================

#smtp inet n - - - - smtpd
#smtp inet n - - - 1 postscreen
#smtpd pass - - - - - smtpd
#dnsblog unix - - - - 0 dnsblog
#tlsproxy unix - - - - 0 tlsproxy
submission inet n - - - - smtpd
-o syslog_name=postfix/submission
-o smtpd_tls_security_level=encrypt
-o smtpd_sasl_auth_enable=yes
-o smtpd_reject_unlisted_recipient=no
-o smtpd_client_restrictions=$mua_client_restrictions
-o smtpd_helo_restrictions=$mua_helo_restrictions
-o smtpd_sender_restrictions=$mua_sender_restrictions
-o smtpd_recipient_restrictions=
-o smtpd_relay_restrictions=permit_sasl_authenticated,reject
-o milter_macro_daemon_name=ORIGINATING
smtps inet n - - - - smtpd
-o syslog_name=postfix/smtps
-o smtpd_tls_wrappermode=yes
-o smtpd_sasl_auth_enable=yes
-o smtpd_reject_unlisted_recipient=no
-o smtpd_client_restrictions=$mua_client_restrictions
-o smtpd_helo_restrictions=$mua_helo_restrictions
-o smtpd_sender_restrictions=$mua_sender_restrictions
-o smtpd_recipient_restrictions=
-o smtpd_relay_restrictions=permit_sasl_authenticated,reject
-o milter_macro_daemon_name=ORIGINATING

10-master.conf

service imap-login {

inet_listener imap {
        #port = 0
}

inet_listener imaps {
    port = 993
    ssl = yes
 }

service lmtp {
      unix_listener /var/spool/postfix/private/dovecot-lmtp {
      mode = 0600
      user = postfix
      group = postfix
  }
}

Any Help will be highly appreciable, Thanks in Advance

More info added below

atul.com is not real domain I changed the name

nslookup
> set type=MX
> atul.com

Non-authoritative answer:
*** Can't find atul.com: No answer

and When I do 

> mail.atul.com
Server:     75.75.75.75
Address:    75.75.75.75#53

Non-authoritative answer:
mail.atul.com   mail exchanger = 10 atul.com.

Authoritative answers can be found from:
0

What you want to do is not possible. You need an open port 25.

Port 587 is the "submission" port, it is used only by end-users wishing to send e-mail through an external SMTP server.

After that, when two servers are communicating with each other to transmit a message to its destination, only port 25 is used.

  • Thanks for your Answer. But Can you please let me know, How it is possible to achieve that? like <br> 1. Do I need to use my ISP's smtp server as Relay host? Because I don't think they allow it. 2. Or I have to purchase a email plan from goDaddy so that I can point to their MX record for all the communication? I will appreciate your kind help... – Tiwari Apr 7 '16 at 14:50
  • Let's say If my ISP allow me on Port 25, than Will I be able to send/receive email outside my domain, If I use below setting? relayhost = mail.atul.com ? – Tiwari Apr 7 '16 at 16:59
  • You should be able to use your ISPs mail server as a relay if you configure Postfix properly (using the relayhost directive). Then your Postfix will behave like an end-user client such as Thunderbird, so in particular for this you can use port 587. – fkraiem Apr 8 '16 at 1:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.