0

I have Lenovo G580 (core i5 2.5 GHz), with dual boot (Windows 7 & Ubuntu 14.04). Since last 3 year, it was running smoothly without any issue.

There was heating issue because of lots dust in cooler. 5 days ago, when i switched on my laptop, the splash screen appeared with message ("Lenovo" and Press F2 ... F12 to choose boot option). From this point everything was normal. After, this screen was blank, no any further processing (GRUB was not loading, from where i used to select an OS to boot).

I switched off the laptop, and again tried to switched, i saw the same problem persist there. Then, i open the back of laptop and removed the RAM and again installed the RAM after cleaning. Then, switched on, It was same as earlier (GRUB was not loading after splash screen). I switched off and switched on again by pressing POWER button, and i kept press F12, to select a source to boot (HDD, DVD, ...) I chosen, HDD to boot, and then GRUB loaded, i choose to boot Windows and then Ubuntu after restart. Both OS was working fine, including GRUB.

But, now this same happening on daily basis. I took the laptop to repairing center, they tried to boot, and same issue came. They pressed F12 and then again GRUB loaded from where they choose to boot, and OS was working very fine without issue. They said there is no issue in your laptop.

When, I shut down / hibernate my laptop and leave it off for an hour or less time. And then switch on, its work fine. But when i switch on the laptop after 8 or more hours , the issue as again there. This is why repairing center couldn't find the issue.

I unable to understand, weather its hardware issue or just issue of GRUB? Please, help me come out from this issue.

Thanks

0

True. It is possible BIOS issue. I have Lenovo laptop too. BIOS upgrade is possible only in windows. You must download the BIOS update file from the lenovo support web page (be sure that you select your exact model of computer!) and follow the instructions there. After update you will not see GRUB anymore. It will boot directly into windows. To repair this you must go into BIOS and under BOOT options select ubuntu (or move it to the top...ubuntu boot manager must be before the windows boot manager)

|improve this answer|||||
  • I have updated the BIOS. And there is no issue of GRUB or anything ... Its just working as earlier :) Thanks – Pavan Apr 10 '16 at 2:59
0

Pavan,

It looks like BIOS related issue. Make sure that you have upgraded to latest BIOS.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.