5

I want to add my internal audio as a recording device so I can record my mic and the computer audio (while wearing headphones) in Audacity.

I'm opening up the sound settings in Ubuntu to get to the following page

enter image description here

How can I add my internal audio to the list here?

3
+100

Most modern sound adapters have output monitoring channels. Unity/Gnome default sound settings tool (part of unity-/gnome-control-center) does not list them on input tab.

  1. Install PulseAudio volume control tool (part of upstream project)

    sudo apt-get install pavucontrol
    
  2. Run it and go to Input Devices tab.

  3. Look down to the right corner, Show: drop list, set it to All Input Devices (Default: All Except Monitors)
  4. As it shows up, you can set it as default.

    picture: pulseaudio volume control - show the monitor lines

If you can't find it, then either it is not supported by driver or hardware itself. You may need to create a virtual loopback.

2
  • 1
    Interesting . As a side note, after selecting "monitor of builtin audio" in "output devices" (and clicking "default" near it) as indicated , i had to select once this input in "recording" tab while Audacity is recording "pulse" input. (look like "default" green button does not work ) – laugeo Apr 9 '16 at 13:12
  • @laugeo, yep by default, it will not change a current running stream (audacity in pause or record state) and will change otherwise. I think that the expected behavior, because you don't want it to change all you previous streams if you have complicated setup to do , example speak with a friend through skype and stream some music to other trough hangout or may be a radio ... simultaneously – user.dz Apr 9 '16 at 13:34
2

This wiki page covers how to create a dummy audio input using PulseAudio, which can then be recording using Audacity.

It uses the PulseAudio Volume Controller (which is available in the default repos, sudo apt-get install pavucontrol), and creates an application stream which Audacity will read as input.

It is much better explained on the above wiki page.

0

First and foremost check the Mic by recording and running the following command in a terminal window:

Make sure the device is not set to Mute, then type

arecord test.wav

and speaking into your microphone. To stop this command press Ctrl+C.

This will test basic recording functionality by creating test.wav in your HOME directory. Open this file to determine whether you successfully captured audio when using the arecord command. This may not work if the system has not detected your input device as default.

NOTE: If this fails, in some cases you may need to configure your ALSA setup or by troubleshooting as per the instructions.

In Audacity:

Go to menu: Edit ▸ Preferences ▸ Devices. Go to section Recording

Choose the appropriate recording device (make sure the device is plugged-in) Click OK

Now Record the audio,Then You should see the audio sensor responding and you should be able to playback the audio.

Else, Try this (#Mitch)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.