1

I tried installing 15.10 on my ssd which is /dev/sdb (unfortunatly),

  • format/set a new gpt partition table to /dev/sda and /dev/sdb and let the installer do its job
  • setup the partitions myself where i used /dev/sdb1 with 530MB as a EFI boot partition, left /dev/sda unformated and installed the root on /dev/sdb2, selected /dev/sdb in the drop down menue for bootloader installation (tried selecting /dev/sdb1 didnt work either)
  • tried creating new partitiontables for ssd and hdd then tried installing it on /dev/sda with letting the installer do the partitions..

sadly, none of these things worked.. only thing which might work is throw out the /dev/sda ..

i tried boot-repair but it tried installing an mbr on a gpt partitioned table? it didnt work anyway so..

the result is always the same: loops back to a (bios-provided)-menue for selecting a boot device.

any ideas..? boot-repair report http://paste.ubuntu.com/15686832/ (the machine is a thinkpad x220)

similar but didnt work (as i tried it) Fresh install of Ubuntu doesnt boot, UEFI. boot-repair doesn't help

  • With UEFI grub only installs to sda, so create an ESP on sda or totally disconnect sda, so current sda is sdb. If it installs to sda, then copy all the files & folders to the ESP on sdb. You will have to use efibootmgr to change entry to new drive. If external drive you have to make shimx64.efi be a new /EFI/Boot/bootx64.efi as external drives only boot from bootx64.efi. Only use gpt: askubuntu.com/questions/559007/… – oldfred Apr 6 '16 at 22:50
  • tried and failed to have it even installed "normally" on /dev/sda ... (without disconnecting /dev/sdb .. even if i disconnect it, i doubt it would work if it doesnt this way) – 4x10 Apr 6 '16 at 23:19
  • What brand/model system and what video card? Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info – oldfred Apr 7 '16 at 3:26
  • thinkpad x220, i5-2520, Intel® HD Graphics 3000, paste.ubuntu.com/15686832 this is the pastebin after i: - left the /dev/sda unformatted - let ubuntu installer do its thing on /dev/sdb - ran boot repair with advanced options to pruge and download the newest version of grub (every command ran without a hitch) – 4x10 Apr 8 '16 at 12:54
  • Have you tried turning secure boot off, but keep UEFI on. Also: Lenovo Thinkpad E531 - turn off locked boot order setting in UEFI ubuntuforums.org/showthread.php?t=2255746 [SOLVED] Error 1962: No operating system found. Lenovo K430 only boot Ubuntu, rename files ubuntuforums.org/showthread.php?t=2243715 Also this may apply, Boot-Repair now renames shimx64.efi to bootx64.efi, but you may not have hard drive UEFI entry in UEFI: Rename bootx64.efi askubuntu.com/questions/597052/… – oldfred Apr 8 '16 at 13:51
1

The Answer is given by oldfred, thank you so much. It`s the third link you posted, which i looked at first.

Renaming your .efi files worked.

But why doesnt grub or boot-repair do that correctly? sigh..

anyway it works, thanks!

Can not boot anymore after a boot repair

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.