117

When I try to restart Samba, I am receiving the following error message:

Failed to start samba.service: Unit samba.service is masked.

In addition, when I run systemctl, it shows smbd.service in red showing failed.

At the same time restart began to fail, I have lost the share ability in folders created and cannot access. Any help would be appreciated!!!

4 Answers 4

167

Debian and debian-derivatives changed the service name from 'samba' to 'smbd'.

Try service smbd restart.

4
  • 1
    anyone know why?
    – Ben Creasy
    Aug 12, 2017 at 19:28
  • 4
    @BenCreasy probably because the protocol's name is smb, and since this is a daemon, you get smbd. Samba is the name of one of the implementations of the smb protocol.
    – terdon
    Nov 6, 2017 at 11:22
  • Job for smbd.service failed because the control process exited with error code. See "systemctl status smbd.service" and "journalctl -xe" for details.
    – M at
    Feb 26, 2018 at 9:38
  • 1
    @M-at That generally means there's an error in your config file. The things it is suggesting you look at will spell that out further.
    – GDorn
    Dec 16, 2020 at 1:20
48

Try:

sudo systemctl unmask samba
sudo systemctl enable samba
sudo systemctl restart samba
7
  • 8
  • 4
    This worked for me with a similar problem with mongodb on Ubuntu 16 after upgrading from 14. I changed the first line, though, to systemctl unmask mongodb.service. After doing this, service mongodb status/start/stop works. Apr 17, 2017 at 19:21
  • Failed to restart samba.service: Unit samba.service is masked.
    – M at
    Feb 26, 2018 at 9:38
  • This seemed to work at first: smbd restarted properly, no logs or errors, but it was still impossible to connect to samba from another machine. The only thing that worked at the end was to uninstall and reinstall samba
    – amine
    Apr 10, 2019 at 12:28
  • same problem as the guy above, only this one solved here Feb 4, 2020 at 21:00
5

This works for me(Ubuntu server 16):

sudo rm /lib/systemd/system/samba.service 
sudo systemctl enable samba.service nmbd.service
sudo systemctl start samba

Found it from here

2
  • I had the same errors as the OP while running Ubuntu 16.04.5 LTS. This solution fixed the issue for me.
    – kneeki
    Sep 27, 2018 at 23:41
  • ouch ls -l /lib/systemd/system/samba.service lrwxrwxrwx 1 root root 9 Mar 5 2018 /lib/systemd/system/samba.service -> /dev/null
    – BozoJoe
    Nov 5, 2018 at 4:24
3

I had the same problem for no apparent reason. Checking the logs I saw that Samba had problems with cached files (improper permissions). rm -R /var/cache/samba/* did the trick.

1
  • Job for smbd.service failed because the control process exited with error code. See "systemctl status smbd.service" and "journalctl -xe" for details.
    – M at
    Feb 26, 2018 at 9:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .